summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-apitrace
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2020-04-16 19:09:45 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-24 09:27:46 -0300
commit3d78ac39525d676ac632dc805831e26293a12b32 (patch)
tree358819bc3e6e455ebbb9a9e7f5089c768f79fc0a /recipes-graphics/imx-gpu-apitrace
parent21599627776a4b5b562121960b66103eb57a3295 (diff)
downloadmeta-freescale-3d78ac39525d676ac632dc805831e26293a12b32.tar.gz
imx-gpu-apitrace: Enable egl and waffle
Add egl and waffle as common configuration. The unique configuration for 8M and 8M Nano is no longer required. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-gpu-apitrace')
-rw-r--r--recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb8
1 files changed, 1 insertions, 7 deletions
diff --git a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb
index 04d84006..9461a34d 100644
--- a/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb
+++ b/recipes-graphics/imx-gpu-apitrace/imx-gpu-apitrace_9.0.0.bb
@@ -11,18 +11,12 @@ S = "${WORKDIR}/git"
11 11
12inherit cmake pkgconfig perlnative python3native 12inherit cmake pkgconfig perlnative python3native
13 13
14PACKAGECONFIG ??= "" 14PACKAGECONFIG ??= "egl waffle"
15PACKAGECONFIG_append = \ 15PACKAGECONFIG_append = \
16 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \ 16 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '', \
17 bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', \ 17 bb.utils.contains('DISTRO_FEATURES', 'x11', ' x11', \
18 '', d), d)}" 18 '', d), d)}"
19PACKAGECONFIG_append_imxgpu2d = " vivante" 19PACKAGECONFIG_append_imxgpu2d = " vivante"
20# For 8M, which has 3D but no 2D, eglretrace is not available
21# on Wayland except through X11 and waffle.
22PACKAGECONFIG_IMXGPU3D = \
23 "${@bb.utils.contains('DISTRO_FEATURES', 'wayland x11', ' waffle x11', '', d)}"
24PACKAGECONFIG_IMXGPU3D_imxgpu2d = ""
25PACKAGECONFIG_append_imxgpu3d = "${PACKAGECONFIG_IMXGPU3D}"
26 20
27PACKAGECONFIG[egl] = "-DENABLE_EGL=ON,-DENABLE_EGL=OFF,virtual/egl" 21PACKAGECONFIG[egl] = "-DENABLE_EGL=ON,-DENABLE_EGL=OFF,virtual/egl"
28PACKAGECONFIG[gui] = "-DENABLE_GUI=ON,-DENABLE_GUI=OFF" 22PACKAGECONFIG[gui] = "-DENABLE_GUI=ON,-DENABLE_GUI=OFF"