summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-02-16 16:01:01 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-02-16 16:21:30 -0700
commitbb2d96bd16a868bc4ae8ea91c1f89b6b07a3c082 (patch)
treec982d6991f65736a571c8989aee42cbd1592d24d /recipes-graphics/imx-g2d
parentbfd03047b7e48235f3e9b6b9cf330971259cda73 (diff)
downloadmeta-freescale-bb2d96bd16a868bc4ae8ea91c1f89b6b07a3c082.tar.gz
imx-pxp-g2d: Add PXP implementation of G2D
Used by i.MX 93. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-pxp-g2d_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-pxp-g2d_git.bb b/recipes-graphics/imx-g2d/imx-pxp-g2d_git.bb
new file mode 100644
index 00000000..fbf56e0c
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-pxp-g2d_git.bb
@@ -0,0 +1,28 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX PXP"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://EULA.txt;md5=d3c315c6eaa43e07d8c130dc3a04a011"
8
9PROVIDES += "virtual/libg2d"
10
11PV = "2.1.0+git${SRCPV}"
12
13SRC_URI = "${IMX_PXP_G2D_SRC};branch=${SRCBRANCH}"
14IMX_PXP_G2D_SRC ?= "git://github.com/nxp-imx/imx-g2d-pxp.git;protocol=https"
15SRCBRANCH ?= "imx_2.1"
16SRCREV = "178970dc7cdba69b94c2219b5bade46d67adb640"
17
18S = "${WORKDIR}/git"
19
20inherit use-imx-headers
21
22EXTRA_OEMAKE = "PLATFORM=IMX93 INCLUDE='-I${STAGING_INCDIR_IMX}' DEST_DIR=${D}"
23
24do_install() {
25 oe_runmake install
26}
27
28COMPATIBLE_MACHINE = "(mx93-nxp-bsp)"