summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-11-16 18:15:35 +0100
committerMax Krummenacher <max.krummenacher@toradex.com>2022-11-18 11:10:08 +0100
commit5e6003bf5add83d67cd8f704d1512ebf5ee18b6f (patch)
tree4fcfeed7e3c3439c3de999ad2bc3c55843bb1025 /recipes-graphics/imx-g2d
parentd92613880280183d438f607ec3c74b549894cbe8 (diff)
downloadmeta-freescale-5e6003bf5add83d67cd8f704d1512ebf5ee18b6f.tar.gz
imx-g2d-samples: update to 2.1, sha 5a38513
Update to the version used in lf5.15.52_2.1.0. imx-g2d-samples now is configured with the BUILD_IMPLEMENTATION environment variable which is expected to be set to one of dpu|gpu-drm|gpu-fbdev depending on the targeted SoC. Commit history: * 5a38513 wayland_dmabuf_test:Convert to xdg-shell * c8167c1 wayland_cf_test:Convert to xdg-shell * 2ccdebe wayland_shm_test:Convert to xdg-shell * 82169b8 LF-6057: g2d_wayland_dmabuf_test had no display * 63272d5 Add multiblit_test build for imx6/7 fbdev * 85ef72a rename extended_test to tiling_test * 2fbe894 YOCIMX-6294: Configure samples to build by implementation * 4f03293 README.md: Cleanup minor issues * 0b6981e MGS-6648 [#ccc] Add Test loop parameter in command line for power measurements Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_git.bb34
1 files changed, 30 insertions, 4 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
index 8368aefc..46bd3a55 100644
--- a/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
@@ -10,15 +10,39 @@ PV = "2.1+git${SRCPV}"
10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}" 10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
11GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https" 11GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
12SRCBRANCH ?= "imx_2.1" 12SRCBRANCH ?= "imx_2.1"
13SRCREV = "3268f291a15b2d8d5f650f627764a52eb0a8fc15" 13SRCREV = "5a38513b97ff83b46777cf73da3cbe37b4976498"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
17inherit pkgconfig 17inherit pkgconfig
18 18
19PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}" 19PACKAGECONFIG ??= "${PACKAGECONFIG_IMPLEMENTATION}"
20 20PACKAGECONFIG_IMPLEMENTATION = ""
21PACKAGECONFIG[wayland] = "USE_WAYLAND=true,USE_WAYLAND=false,wayland-native wayland-protocols" 21PACKAGECONFIG_IMPLEMENTATION:imxgpu2d:imxdpu = "dpu"
22PACKAGECONFIG_IMPLEMENTATION:imxgpu2d = "gpu-drm"
23PACKAGECONFIG_IMPLEMENTATION:imxgpu2d:imxfbdev = "gpu-fbdev"
24
25PACKAGECONFIG[dpu] = " \
26 BUILD_IMPLEMENTATION=dpu, \
27 , \
28 imx-dpu-g2d wayland-native wayland-protocols, \
29 , \
30 , \
31 gpu-drm gpu-fbdev"
32PACKAGECONFIG[gpu-drm] = " \
33 BUILD_IMPLEMENTATION=gpu-drm, \
34 , \
35 imx-gpu-g2d wayland-native wayland-protocols, \
36 , \
37 , \
38 dpu gpu-fbdev"
39PACKAGECONFIG[gpu-fbdev] = " \
40 BUILD_IMPLEMENTATION=gpu-fbdev, \
41 , \
42 imx-gpu-g2d, \
43 , \
44 , \
45 dpu gpu-drm"
22 46
23EXTRA_OEMAKE += " \ 47EXTRA_OEMAKE += " \
24 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ 48 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
@@ -31,4 +55,6 @@ do_install() {
31 55
32FILES:${PN} += "/opt" 56FILES:${PN} += "/opt"
33 57
58PACKAGE_ARCH = "${MACHINE_SOCARCH}"
59
34COMPATIBLE_MACHINE = "(imxgpu2d)" 60COMPATIBLE_MACHINE = "(imxgpu2d)"