summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-05-11 10:52:47 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-05-11 13:12:29 -0500
commit5c9e98440a5b84711f0cc5ae340e0ab1de8de123 (patch)
tree3ea1cb0e9cb2d16dbefb9cb5b21e15d63832c583 /recipes-graphics/imx-g2d
parent015caea5c777384b44dda89e8c76dadaecc84ddc (diff)
downloadmeta-freescale-5c9e98440a5b84711f0cc5ae340e0ab1de8de123.tar.gz
imx-g2d-samples: Upgrade 1.0.0 -> 2.0.0
This version of samples supports DPU-based G2D, using G2D API 2.0. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb25
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb32
2 files changed, 32 insertions, 25 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
deleted file mode 100644
index 984c10fc..00000000
--- a/recipes-graphics/imx-g2d/imx-g2d-samples_1.0.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5
6# This package is currently only for GPU-based G2D. Support for DPU-based G2d is coming.
7DEPENDS = "imx-gpu-g2d"
8
9GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
10SRCBRANCH ?= "imx_1.0"
11SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
12SRCREV = "daf64d010666ef2458566573c074e238993f228c"
13
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D} PREFIX=${exec_prefix}
20}
21
22FILES:${PN} += "/opt"
23
24COMPATIBLE_MACHINE = "(imxgpu2d)"
25
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb
new file mode 100644
index 00000000..9832aac2
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_2.0.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5
6DEPENDS = "virtual/libg2d"
7
8GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxpmicro/g2d-samples.git;protocol=https"
9SRCBRANCH ?= "imx_2.0"
10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
11SRCREV = "267af142881d350218c2c2cead8f304a28bbee07"
12
13S = "${WORKDIR}/git"
14
15inherit pkgconfig
16
17PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland', d)}"
18
19PACKAGECONFIG[wayland] = "USE_WAYLAND=true,USE_WAYLAND=false,wayland-native wayland-protocols"
20
21EXTRA_OEMAKE += " \
22 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
23 ${PACKAGECONFIG_CONFARGS} \
24"
25
26do_install() {
27 oe_runmake install DESTDIR=${D}
28}
29
30FILES:${PN} += "/opt"
31
32COMPATIBLE_MACHINE = "(imxgpu2d)"