summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-05-16 13:02:16 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-05-17 05:48:18 -0700
commit4344c161fcdddb4f0059cb6fd0a8fb2c924c54b0 (patch)
tree92ce2741e13ad70fd1f3242e0b57ee031364a087 /recipes-graphics/imx-g2d
parent128523cdfbd167dcd4e27422d6e66f065831857e (diff)
downloadmeta-freescale-4344c161fcdddb4f0059cb6fd0a8fb2c924c54b0.tar.gz
imx-g2d-samples: Upgrade to a5f620f
- Add support for PXP-based G2D - Make wayland dependencies explicit - Drop virtual/libg2d dependency as redundant to PACKAGECONFIG Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d')
-rw-r--r--recipes-graphics/imx-g2d/imx-g2d-samples_git.bb26
1 files changed, 17 insertions, 9 deletions
diff --git a/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb b/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
index c02a4f50..c5f2158e 100644
--- a/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
+++ b/recipes-graphics/imx-g2d/imx-g2d-samples_git.bb
@@ -1,16 +1,16 @@
1SUMMARY = "i.MX G2D Samples" 1SUMMARY = "i.MX G2D Samples"
2DESCRIPTION = "Set of sample applications for i.MX G2D" 2DESCRIPTION = "Set of sample applications for i.MX G2D"
3LICENSE = "BSD-3-Clause" 3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0858ec9c7a80c4a2cf16e4f825a2cc91" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=0858ec9c7a80c4a2cf16e4f825a2cc91"
5 5
6DEPENDS = "virtual/libg2d cairo" 6DEPENDS = "cairo"
7 7
8PV = "2.1+git${SRCPV}" 8PV = "2.1+git${SRCPV}"
9 9
10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}" 10SRC_URI = "${GPU_G2D_SAMPLES_SRC};branch=${SRCBRANCH}"
11GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxp-imx/g2d-samples.git;protocol=https" 11GPU_G2D_SAMPLES_SRC ?= "git://github.com/nxp-imx/g2d-samples.git;protocol=https"
12SRCBRANCH ?= "imx_2.1" 12SRCBRANCH ?= "imx_2.1"
13SRCREV = "3efd75a90e3c606c9b7bed6791bcd4085ae69b9b" 13SRCREV = "a5f620fcf0e986a19e4acdfa48c95eaf79a5c570"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
@@ -21,28 +21,36 @@ PACKAGECONFIG_IMPLEMENTATION = ""
21PACKAGECONFIG_IMPLEMENTATION:imxgpu2d:imxdpu = "dpu" 21PACKAGECONFIG_IMPLEMENTATION:imxgpu2d:imxdpu = "dpu"
22PACKAGECONFIG_IMPLEMENTATION:imxgpu2d = "gpu-drm" 22PACKAGECONFIG_IMPLEMENTATION:imxgpu2d = "gpu-drm"
23PACKAGECONFIG_IMPLEMENTATION:imxgpu2d:imxfbdev = "gpu-fbdev" 23PACKAGECONFIG_IMPLEMENTATION:imxgpu2d:imxfbdev = "gpu-fbdev"
24PACKAGECONFIG_IMPLEMENTATION:mx93-nxp-bsp = "pxp"
24 25
25PACKAGECONFIG[dpu] = " \ 26PACKAGECONFIG[dpu] = " \
26 BUILD_IMPLEMENTATION=dpu, \ 27 BUILD_IMPLEMENTATION=dpu, \
27 , \ 28 , \
28 imx-dpu-g2d wayland-native wayland-protocols, \ 29 imx-dpu-g2d wayland-native wayland wayland-protocols, \
29 , \ 30 , \
30 , \ 31 , \
31 gpu-drm gpu-fbdev" 32 gpu-drm gpu-fbdev pxp"
32PACKAGECONFIG[gpu-drm] = " \ 33PACKAGECONFIG[gpu-drm] = " \
33 BUILD_IMPLEMENTATION=gpu-drm, \ 34 BUILD_IMPLEMENTATION=gpu-drm, \
34 , \ 35 , \
35 imx-gpu-g2d wayland-native wayland-protocols, \ 36 imx-gpu-g2d wayland-native wayland wayland-protocols, \
36 , \ 37 , \
37 , \ 38 , \
38 dpu gpu-fbdev" 39 dpu gpu-fbdev pxp"
39PACKAGECONFIG[gpu-fbdev] = " \ 40PACKAGECONFIG[gpu-fbdev] = " \
40 BUILD_IMPLEMENTATION=gpu-fbdev, \ 41 BUILD_IMPLEMENTATION=gpu-fbdev, \
41 , \ 42 , \
42 imx-gpu-g2d, \ 43 imx-gpu-g2d, \
43 , \ 44 , \
44 , \ 45 , \
45 dpu gpu-drm" 46 dpu gpu-drm pxp"
47PACKAGECONFIG[pxp] = " \
48 BUILD_IMPLEMENTATION=pxp, \
49 , \
50 imx-pxp-g2d wayland-native wayland wayland-protocols, \
51 , \
52 , \
53 dpu gpu-drm gpu-fbdev"
46 54
47EXTRA_OEMAKE += " \ 55EXTRA_OEMAKE += " \
48 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \ 56 SDKTARGETSYSROOT=${STAGING_DIR_HOST} \
@@ -57,4 +65,4 @@ FILES:${PN} += "/opt"
57 65
58PACKAGE_ARCH = "${MACHINE_SOCARCH}" 66PACKAGE_ARCH = "${MACHINE_SOCARCH}"
59 67
60COMPATIBLE_MACHINE = "(imxgpu2d)" 68COMPATIBLE_MACHINE = "(imxgpu2d|mx93-nxp-bsp)"