summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-11-15 18:01:50 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-11-18 11:38:56 +0000
commit50694a5c2b0543dce00e7d9d43d4a827be3124d2 (patch)
tree8cfcea8c030bd48d2cc354e9d08c6f0f7e039ec7 /recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb
parent2876ad5de5a6ca0cc2a16af2228f10a8667db04d (diff)
downloadmeta-freescale-50694a5c2b0543dce00e7d9d43d4a827be3124d2.tar.gz
imx-gpu-g2d: update from 6.4.3.p4.2 to 6.4.3.p4.4
Update to the version used in lf5.15.52_2.1.0. License was updated to NXP EULA v39 August 2022. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 97fae3422d575110346b5238a758d343376ef2d1)
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb
new file mode 100644
index 00000000..524f15e9
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-gpu-g2d_6.4.3.p4.4.bb
@@ -0,0 +1,33 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Copyright 2018 (C) O.S. Systems Software LTDA.
4# Released under the MIT license (see COPYING.MIT for the terms)
5
6DESCRIPTION = "G2D library using i.MX GPU"
7LICENSE = "Proprietary"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
9DEPENDS = "libgal-imx"
10PROVIDES = "virtual/libg2d"
11
12FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
13
14SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
15SRC_URI[aarch64.md5sum] = "98d46bca2ae66e31b7e4878a7b622b99"
16SRC_URI[aarch64.sha256sum] = "8341d6e2cde3f3ffa035dc95b0487dd04a50531cc80f4cddc5a689ebc4946e02"
17SRC_URI[arm.md5sum] = "ff96d069092424a50ba4542d6ef5e931"
18SRC_URI[arm.sha256sum] = "7737a3372bcde34e2d275397df67c307df5033d5b133ac770f75cac4e1ec2580"
19
20S = "${WORKDIR}/${FSLBIN_NAME}"
21
22inherit fsl-eula-unpack
23
24do_install () {
25 install -d ${D}${libdir}
26 install -d ${D}${includedir}
27 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
28 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
29}
30
31INSANE_SKIP:${PN} = "ldflags"
32
33COMPATIBLE_MACHINE = "(imxgpu2d)"