summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-05-16 12:57:41 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-05-17 05:47:33 -0700
commita8e29c1fc01f234bf4f84f05a1687621f0494eca (patch)
tree3db556a240b31da179e722e87ed24854dfb23220 /recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb
parent098012ba8e30ba82afbbe708243879bafd62308e (diff)
downloadmeta-freescale-a8e29c1fc01f234bf4f84f05a1687621f0494eca.tar.gz
imx-dpu-g2d: Upgrade 2.1.4 -> 2.1.6
Changes: ``` d1b7402 MGS-7007: Add log when creating OpenCL kernel file 622cb9e LF-7929: Fix YUV video color shift when using DPU 2D ``` Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb
new file mode 100644
index 00000000..8d26e7a5
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.6.bb
@@ -0,0 +1,35 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=ea25d099982d035af85d193c88a1b479"
8
9DEPENDS = "libgal-imx libdrm"
10PROVIDES += "virtual/libg2d"
11
12SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
13SRC_URI[md5sum] = "ab5972089fe8746dc5fa5388e432a154"
14SRC_URI[sha256sum] = "771d71b5766f148bfb349cbc069a1808ad43f881d17cb11ec2ca27a959a9ad34"
15
16inherit fsl-eula-unpack
17
18do_install () {
19 install -d ${D}${libdir}
20 install -d ${D}${includedir}
21 cp -d ${S}/g2d/usr/lib/*.so* ${D}${libdir}
22 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
23}
24
25INSANE_SKIP:${PN} += "ldflags"
26INSANE_SKIP:append:libc-musl = " file-rdeps"
27RDEPENDS:${PN}:append:libc-musl = " gcompat"
28
29# The packaged binaries have been stripped of debug info, so disable
30# operations accordingly.
31INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
32INHIBIT_PACKAGE_STRIP = "1"
33INHIBIT_SYSROOT_STRIP = "1"
34
35COMPATIBLE_MACHINE = "(imxdpu)"