summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-11-18 08:49:13 -0300
committerGitHub <noreply@github.com>2022-11-18 08:49:13 -0300
commitfefd97bc11f51948f4a77cbfcbe74c5c731d4ec6 (patch)
tree21c06cce11f0ce0539679a46e8056e39e3d48cb2 /recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb
parent5af267b681f48c14780f3a1a61c4df25796d4a51 (diff)
parent09f140816b52a1f8aefcf156affac452b3274a45 (diff)
downloadmeta-freescale-fefd97bc11f51948f4a77cbfcbe74c5c731d4ec6.tar.gz
Merge pull request #1307 from Freescale/backport-1306-to-kirkstone
[Backport kirkstone] Upgrade Graphics Packages to lf5.15.52_2.1.0
Diffstat (limited to 'recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb')
-rw-r--r--recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb
new file mode 100644
index 00000000..b3bcbdf1
--- /dev/null
+++ b/recipes-graphics/imx-g2d/imx-dpu-g2d_2.1.2.bb
@@ -0,0 +1,30 @@
1# Copyright (C) 2016 Freescale Semiconductor
2# Copyright 2017-2022 NXP
3# Released under the MIT license (see COPYING.MIT for the terms)
4
5DESCRIPTION = "G2D library using i.MX DPU"
6LICENSE = "Proprietary"
7LIC_FILES_CHKSUM = "file://COPYING;md5=5a0bf11f745e68024f37b4724a5364fe"
8
9DEPENDS = "libgal-imx libdrm"
10PROVIDES += "virtual/libg2d"
11
12SRC_URI = "${FSL_MIRROR}/${BPN}-${PV}.bin;fsl-eula=true"
13SRC_URI[md5sum] = "85daf26176695de80a024b5f67037f08"
14SRC_URI[sha256sum] = "1023814d810c0a85c91cb2170c77f663f624331261ba0e1ab1ce29e8c192e1bc"
15
16inherit fsl-eula-unpack
17
18do_install () {
19 install -d ${D}${libdir}
20 install -d ${D}${includedir}
21 cp -r ${S}/g2d/usr/lib/*.so* ${D}${libdir}
22 cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
23}
24
25INSANE_SKIP:${PN} += "ldflags"
26INSANE_SKIP:append:libc-musl = " file-rdeps"
27
28COMPATIBLE_MACHINE = "(imxdpu)"
29
30RDEPENDS:${PN}:append:libc-musl = " gcompat"