summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/gtk+
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2022-09-15 10:41:15 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2022-09-15 10:41:15 -0500
commite3f41f8c93ab66b1f124059cf5ce3d24b148285b (patch)
tree30dd6865d03e5a9d7941d6bfea462f0a1bca4335 /recipes-graphics/gtk+
parent952a6084f3c2fc7aab6a0239c19e011770f76d38 (diff)
downloadmeta-freescale-e3f41f8c93ab66b1f124059cf5ce3d24b148285b.tar.gz
gtk+3: Drop x11 config logic
The original intent of dropping x11 support from the package was so only wayland would be supported. The fix in efcb2fe and 7447f7c removes that. However, it keeps the idea that the x11 packageconfig should be disallowed from being added if x11 is not in the distro features. This was never the intent of the original logic, and since the default is to enable x11 packageconfig if and only if x11 is a distro feature, just drop the logic entirely. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-graphics/gtk+')
-rw-r--r--recipes-graphics/gtk+/gtk+3_%.bbappend5
1 files changed, 0 insertions, 5 deletions
diff --git a/recipes-graphics/gtk+/gtk+3_%.bbappend b/recipes-graphics/gtk+/gtk+3_%.bbappend
index c4fdfff9..6bc01807 100644
--- a/recipes-graphics/gtk+/gtk+3_%.bbappend
+++ b/recipes-graphics/gtk+/gtk+3_%.bbappend
@@ -1,6 +1 @@
1DEPENDS:append:imxgpu2d = " virtual/egl" DEPENDS:append:imxgpu2d = " virtual/egl"
2
3WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'x11', d)}"
4WAYLANDONLY = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', '${WAYLAND}', '', d)}"
5
6PACKAGECONFIG:remove:imxgpu2d = " ${WAYLANDONLY}"