summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/drm
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2019-04-29 20:29:05 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-05-05 16:23:48 -0300
commit1337021d13afd96243d9276f0a99114cd8c0297e (patch)
tree39b3871120861b6450ab2f4e6163831673c06b3f /recipes-graphics/drm
parent99c797bd2f5c985606fb00f1e5ede878aa4ca829 (diff)
downloadmeta-freescale-1337021d13afd96243d9276f0a99114cd8c0297e.tar.gz
libdrm: prevent warning on mx8
i.MX8 also uses the override imxgpu2d, so provide the patch for that override, not individual SoC Archs. Prevents: | .../meta/recipes-graphics/drm/libdrm_2.4.94.bb: Unable to get checksum for libdrm SRC_URI entry drm-update-arm.patch: file could not be found Note that __arm__ is not defined in aarch64 gcc, so applying the patch has no effect. Should it be needed one would have to rework to patch to also provide assembler code for aarch64 in an appropriate #ifdef section. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-graphics/drm')
-rw-r--r--recipes-graphics/drm/libdrm/imxgpu2d/drm-update-arm.patch (renamed from recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch)0
-rw-r--r--recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch35
2 files changed, 0 insertions, 35 deletions
diff --git a/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch b/recipes-graphics/drm/libdrm/imxgpu2d/drm-update-arm.patch
index 1160cd10..1160cd10 100644
--- a/recipes-graphics/drm/libdrm/mx6/drm-update-arm.patch
+++ b/recipes-graphics/drm/libdrm/imxgpu2d/drm-update-arm.patch
diff --git a/recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch b/recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch
deleted file mode 100644
index 1160cd10..00000000
--- a/recipes-graphics/drm/libdrm/mx7/drm-update-arm.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1Add ARM support into xf86arm.h. This provides support for Xorg interface.
2Without this the vivante samples will hang during close requiring a reboot
3
4Upstream-Status: Pending
5
6Signed-off-by: Lauren Post <lauren.post@freescale.com>
7Signed-off-by: Evan Kotara <evan.kotara@freescale.com>
8
9diff --git a/xf86drm.h b/xf86drm.h
10--- a/xf86drm.h
11+++ b/xf86drm.h
12@@ -461,6 +461,23 @@ do { register unsigned int __old __asm("
13 : "cr0", "memory"); \
14 } while (0)
15
16+#elif defined(__arm__)
17+ #undef DRM_DEV_MODE
18+ #define DRM_DEV_MODE (S_IRUSR|S_IWUSR|S_IRGRP|S_IWGRP|S_IROTH|S_IWOTH)
19+
20+ #define DRM_CAS(lock,old,new,__ret) \
21+ do { \
22+ __asm__ __volatile__ ( \
23+ "1: ldrex %0, [%1]\n" \
24+ " teq %0, %2\n" \
25+ " ite eq\n" \
26+ " strexeq %0, %3, [%1]\n" \
27+ " movne %0, #1\n" \
28+ : "=&r" (__ret) \
29+ : "r" (lock), "r" (old), "r" (new) \
30+ : "cc","memory"); \
31+ } while (0)
32+
33 #endif /* architecture */
34 #endif /* __GNUC__ >= 2 */
35