summaryrefslogtreecommitdiffstats
path: root/recipes-graphics/cairo
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-17 10:01:30 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-19 14:06:35 -0700
commitfa4112e43fc4edc4a8521eddd459606328be647e (patch)
tree5fa13cf5b94cae0ecd522fb561017d43468f4ac8 /recipes-graphics/cairo
parent61718793a4c04c768ecc829372b9d4de3c6c463b (diff)
downloadmeta-freescale-fa4112e43fc4edc4a8521eddd459606328be647e.tar.gz
cairo,xwayland: Fix compiling with musl with vivante gpu driver libs
This ensures that the symbols from the prebuilt libs are not flagged during build, we are betting on gcompat to provide the missing glibc API stubs at runtime. Depend on gcompat on musl needed for imxgpu machines its needed since graphics driver is precompiled for glibc. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-graphics/cairo')
-rw-r--r--recipes-graphics/cairo/cairo_%.bbappend2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-graphics/cairo/cairo_%.bbappend b/recipes-graphics/cairo/cairo_%.bbappend
index 245adb59..c61e9a58 100644
--- a/recipes-graphics/cairo/cairo_%.bbappend
+++ b/recipes-graphics/cairo/cairo_%.bbappend
@@ -3,6 +3,6 @@ PACKAGECONFIG:remove:imxgpu3d = "opengl"
3 3
4# links with imx-gpu libs which are pre-built for glibc 4# links with imx-gpu libs which are pre-built for glibc
5# gcompat will address it during runtime 5# gcompat will address it during runtime
6LDFLAGS:append:imxgpu3d:libc-musl = " -Wl,--allow-shlib-undefined"
7LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined" 6LDFLAGS:append:imxgpu:libc-musl = " -Wl,--allow-shlib-undefined"
8 7
8RDEPENDS:${PN}:append:imxgpu:libc-musl = " gcompat"