summaryrefslogtreecommitdiffstats
path: root/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
diff options
context:
space:
mode:
authorDaiane Angolini <daiane.angolini@foundries.io>2023-07-26 17:19:25 -0300
committerDaiane Angolini <daiane.angolini@foundries.io>2023-07-26 19:37:48 -0300
commitcfeb85ce48fcd54b5e8ff4ce72d56f79d10c929f (patch)
tree2438c56a3348a43e151056553a1bb39f280f0df0 /recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
parent70676ce1e890f6061313c15fcfe7e6f75395f0dd (diff)
downloadmeta-freescale-cfeb85ce48fcd54b5e8ff4ce72d56f79d10c929f.tar.gz
mcore-demos: imx-m4-demos: Add package based on 6.1.22-2.0.0
Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
Diffstat (limited to 'recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb')
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
new file mode 100644
index 00000000..fd99c637
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
@@ -0,0 +1,28 @@
1SUMMARY = "i.MX M4 core Demo images"
2SECTION = "app"
3LICENSE = "Proprietary"
4LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"
5
6inherit deploy fsl-eula-unpack
7
8M4_SOC ?= "INVALID"
9M4_SOC:mx7d-nxp-bsp = "imx7d-sabresd"
10
11SRC_URI = "${FSL_MIRROR}/${M4_SOC}-m4-freertos-${PV}.bin;fsl-eula=true"
12S = "${WORKDIR}/${M4_SOC}-m4-freertos-${PV}"
13
14SRC_URI[md5sum] = "b05b780ff3916f4953ab58ac95233c38"
15SRC_URI[sha256sum] = "cc00d3b936d49b2794a2a99e10129437e70caba3fd26b8379b8c50dd22f73254"
16
17do_deploy () {
18 # Install the demo binaries
19 install -d ${DEPLOYDIR}
20 cp ${S}/*.bin ${DEPLOYDIR}/
21 ls ${DEPLOYDIR}/
22}
23
24addtask deploy before do_build after do_compile
25
26PACKAGE_ARCH = "${MACHINE_SOCARCH}"
27COMPATIBLE_MACHINE = "(mx7d-nxp-bsp)"
28