summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorJose Quaresma <jose.quaresma@foundries.io>2024-01-25 14:29:24 +0000
committerJose Quaresma <jose.quaresma@foundries.io>2024-01-25 14:29:24 +0000
commit8c714143f4487c07515056be1da696cd73052e0a (patch)
treee2bc932e5f5e12da80ed429b3cd82f8ff659cdaa /recipes-extended
parent764794776ed00cd59e1ae4893cfcbff1f0a10f56 (diff)
downloadmeta-freescale-8c714143f4487c07515056be1da696cd73052e0a.tar.gz
jailhouse-imx: fix bitbake tasks overrides
Overriding do_configure will skip: setup_target_config setuptools3_do_configure Using prepend in do_install will result in the call of python3 pip directly inside of oe_runmake instead of using the functions [1] resulting in install the python stuff to a wrong target path which includes the HOME directory of the user who runs bitbake. [1] setup_target_config setuptools3_do_install python_pep517_do_install Signed-off-by: Jose Quaresma <jose.quaresma@foundries.io>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/jailhouse/jailhouse-imx_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-extended/jailhouse/jailhouse-imx_git.bb b/recipes-extended/jailhouse/jailhouse-imx_git.bb
index 7eba3a43..f275274d 100644
--- a/recipes-extended/jailhouse/jailhouse-imx_git.bb
+++ b/recipes-extended/jailhouse/jailhouse-imx_git.bb
@@ -41,7 +41,7 @@ INMATES_DIR ?= "${JH_DATADIR}/inmates"
41 41
42TUNE_CCARGS:remove:mx93-nxp-bsp = "-mcpu=cortex-a55" 42TUNE_CCARGS:remove:mx93-nxp-bsp = "-mcpu=cortex-a55"
43 43
44do_configure() { 44do_configure:prepend() {
45 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ]; 45 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ];
46 then 46 then
47 cp "${STAGING_DIR_HOST}/${CELLCONF_DIR}/"*.c ${S}/configs/${ARCH}/ 47 cp "${STAGING_DIR_HOST}/${CELLCONF_DIR}/"*.c ${S}/configs/${ARCH}/
@@ -55,7 +55,7 @@ do_compile:prepend() {
55 KDIR=${STAGING_KERNEL_BUILDDIR} 55 KDIR=${STAGING_KERNEL_BUILDDIR}
56} 56}
57 57
58do_install:prepend() { 58do_install:append() {
59 oe_runmake \ 59 oe_runmake \
60 PYTHON=python3 \ 60 PYTHON=python3 \
61 V=1 \ 61 V=1 \