summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-05-18 14:04:49 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-08-12 11:41:02 -0300
commit89d0858107f6532a6a94710eedc2caf4286e1024 (patch)
treec6197a01634a17bf3e98ce825088aafa4b654b23 /recipes-extended
parent270498eba25c5fca0c319a8b0af77a0a2cd2419a (diff)
downloadmeta-freescale-89d0858107f6532a6a94710eedc2caf4286e1024.tar.gz
fsl-pme: add recipe
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/fsl-pme/fsl-pme_1.0.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb b/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb
new file mode 100644
index 00000000..7fe11fda
--- /dev/null
+++ b/recipes-extended/fsl-pme/fsl-pme_1.0.3.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "User space application for Pattern Matcher"
2LICENSE = "Freescale-EULA"
3LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
4
5DEPENDS="libedit"
6RDEPENDS_${PN} += "bash"
7
8SRC_URI = "git://git.freescale.com/ppc/sdk/fsl-pme.git;branch=sdk-v2.0.x"
9SRCREV = "f49fb57960ff5ee649be97a9587ede88e433ea71"
10
11S = "${WORKDIR}/git"
12
13EXTRA_OEMAKE = 'CC="${CC}" AR="${AR}" SYS_PATH=${STAGING_LIBDIR}/..'
14do_install() {
15 install -d ${D}${datadir}/fsl-pme
16 install -d ${D}${base_sbindir}
17 install -d ${D}${sysconfdir}/hotplug
18 install bin/* ${D}${base_sbindir}/
19 install -m 644 sample* ${D}${datadir}/fsl-pme/
20 install -m 644 modprobe.conf ${D}${sysconfdir}
21 install -m 755 misc.agent ${D}${sysconfdir}/hotplug
22}
23
24FILES_${PN} += "${datadir}/*"
25INSANE_SKIP_${PN} += "ldflags"
26COMPATIBLE_MACHINE = "(e500v2)"