summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-04-21 07:50:03 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 09:42:12 -0300
commit80a1e3a02dd634e0c2703dddb0e83e7385310040 (patch)
treec30c2c4326f9bb9b739d569116d795788782b39e /recipes-extended
parent287c0cbbb32348b02c8069e16ae7122b43d0cafe (diff)
downloadmeta-freescale-80a1e3a02dd634e0c2703dddb0e83e7385310040.tar.gz
dpdk: update scripts to use python3
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/dpdk/dpdk/0005-use-python3-instead-of-python.patch100
-rw-r--r--recipes-extended/dpdk/dpdk_19.11-20.04.bb3
2 files changed, 102 insertions, 1 deletions
diff --git a/recipes-extended/dpdk/dpdk/0005-use-python3-instead-of-python.patch b/recipes-extended/dpdk/dpdk/0005-use-python3-instead-of-python.patch
new file mode 100644
index 00000000..81ca1244
--- /dev/null
+++ b/recipes-extended/dpdk/dpdk/0005-use-python3-instead-of-python.patch
@@ -0,0 +1,100 @@
1diff --git a/app/test-bbdev/test-bbdev.py b/app/test-bbdev/test-bbdev.py
2index 0194be046..86fe3a89d 100755
3--- a/app/test-bbdev/test-bbdev.py
4+++ b/app/test-bbdev/test-bbdev.py
5@@ -1,4 +1,4 @@
6-#!/usr/bin/env python
7+#!/usr/bin/env python3
8
9 # SPDX-License-Identifier: BSD-3-Clause
10 # Copyright(c) 2017 Intel Corporation
11diff --git a/app/test-cmdline/cmdline_test.py b/app/test-cmdline/cmdline_test.py
12index 3a8fac426..231fe6032 100755
13--- a/app/test-cmdline/cmdline_test.py
14+++ b/app/test-cmdline/cmdline_test.py
15@@ -1,4 +1,4 @@
16-#!/usr/bin/env python
17+#!/usr/bin/env python3
18 # SPDX-License-Identifier: BSD-3-Clause
19 # Copyright(c) 2010-2014 Intel Corporation
20
21diff --git a/app/test/autotest.py b/app/test/autotest.py
22index b42f48879..30541d102 100644
23--- a/app/test/autotest.py
24+++ b/app/test/autotest.py
25@@ -1,4 +1,4 @@
26-#!/usr/bin/env python
27+#!/usr/bin/env python3
28 # SPDX-License-Identifier: BSD-3-Clause
29 # Copyright(c) 2010-2014 Intel Corporation
30
31diff --git a/buildtools/map_to_def.py b/buildtools/map_to_def.py
32index 6775b54a9..ff67f0a35 100644
33--- a/buildtools/map_to_def.py
34+++ b/buildtools/map_to_def.py
35@@ -1,4 +1,4 @@
36-#!/usr/bin/env python
37+#!/usr/bin/env python3
38 # SPDX-License-Identifier: BSD-3-Clause
39 # Copyright(c) 2019 Intel Corporation
40
41diff --git a/config/arm/armv8_machine.py b/config/arm/armv8_machine.py
42index 404866d2f..1f689d9a8 100755
43--- a/config/arm/armv8_machine.py
44+++ b/config/arm/armv8_machine.py
45@@ -1,4 +1,4 @@
46-#!/usr/bin/python
47+#!/usr/bin/env python3
48 # SPDX-License-Identifier: BSD-3-Clause
49 # Copyright(c) 2017 Cavium, Inc
50
51diff --git a/devtools/update_version_map_abi.py b/devtools/update_version_map_abi.py
52index 616412a1c..3244b0984 100755
53--- a/devtools/update_version_map_abi.py
54+++ b/devtools/update_version_map_abi.py
55@@ -1,4 +1,4 @@
56-#!/usr/bin/env python
57+#!/usr/bin/env python3
58 # SPDX-License-Identifier: BSD-3-Clause
59 # Copyright(c) 2019 Intel Corporation
60
61diff --git a/usertools/cpu_layout.py b/usertools/cpu_layout.py
62index 6f129b1db..e86bf6b92 100755
63--- a/usertools/cpu_layout.py
64+++ b/usertools/cpu_layout.py
65@@ -1,4 +1,4 @@
66-#!/usr/bin/env python
67+#!/usr/bin/env python3
68 # SPDX-License-Identifier: BSD-3-Clause
69 # Copyright(c) 2010-2014 Intel Corporation
70 # Copyright(c) 2017 Cavium, Inc. All rights reserved.
71diff --git a/usertools/dpdk-devbind.py b/usertools/dpdk-devbind.py
72index b1d149876..3f8175338 100755
73--- a/usertools/dpdk-devbind.py
74+++ b/usertools/dpdk-devbind.py
75@@ -1,4 +1,4 @@
76-#! /usr/bin/env python
77+#!/usr/bin/env python3
78 # SPDX-License-Identifier: BSD-3-Clause
79 # Copyright(c) 2010-2014 Intel Corporation
80 #
81diff --git a/usertools/dpdk-pmdinfo.py b/usertools/dpdk-pmdinfo.py
82index 069a3bf12..1d5c99c2a 100755
83--- a/usertools/dpdk-pmdinfo.py
84+++ b/usertools/dpdk-pmdinfo.py
85@@ -1,4 +1,4 @@
86-#!/usr/bin/env python
87+#!/usr/bin/env python3
88 # SPDX-License-Identifier: BSD-3-Clause
89 # Copyright(c) 2016 Neil Horman <nhorman@tuxdriver.com>
90
91diff --git a/usertools/dpdk-telemetry-client.py b/usertools/dpdk-telemetry-client.py
92index 290345dcc..279067450 100755
93--- a/usertools/dpdk-telemetry-client.py
94+++ b/usertools/dpdk-telemetry-client.py
95@@ -1,4 +1,4 @@
96-#! /usr/bin/env python
97+#!/usr/bin/env python3
98 # SPDX-License-Identifier: BSD-3-Clause
99 # Copyright(c) 2018 Intel Corporation
100
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.04.bb b/recipes-extended/dpdk/dpdk_19.11-20.04.bb
index cd33a3b6..53ee5095 100644
--- a/recipes-extended/dpdk/dpdk_19.11-20.04.bb
+++ b/recipes-extended/dpdk/dpdk_19.11-20.04.bb
@@ -8,7 +8,8 @@ SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dpdk;nobr
8 file://0001-add-Wno-cast-function-type.patch \ 8 file://0001-add-Wno-cast-function-type.patch \
9 file://0001-Add-RTE_KERNELDIR_OUT.patch \ 9 file://0001-Add-RTE_KERNELDIR_OUT.patch \
10 file://0004-update-WERROR_FLAGS.patch \ 10 file://0004-update-WERROR_FLAGS.patch \
11 file://0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch \ 11 file://0001-examples-ipsec-gw-fix-gcc-10-maybe-uninitialized-war.patch \
12 file://0005-use-python3-instead-of-python.patch \
12" 13"
13SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540" 14SRCREV = "4110a5fed09fa034963cfc246a6285911ecbd540"
14 15