summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2021-10-14 16:42:40 +0800
committerTing Liu <ting.liu@nxp.com>2021-10-15 22:11:36 +0800
commit6ab74151605998436d2480d90d6d5d9efeab1d91 (patch)
tree6fce561222f72d0523fa18e8d314a82c614d4d6f /recipes-extended
parentbd9de08cc72d1a3a1a4d8a58bc9f5df9171bbc35 (diff)
downloadmeta-freescale-6ab74151605998436d2480d90d6d5d9efeab1d91.tar.gz
ovs-dpdk: upgrade to 2.15
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb48
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb36
2 files changed, 36 insertions, 48 deletions
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
deleted file mode 100644
index f9d32773..00000000
--- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1DESCRIPTION = "OVS DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4
5DEPENDS = "dpdk python3-six-native coreutils-native"
6RDEPENDS:${PN} = "bash libcrypto libssl python3"
7
8inherit python3native
9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1"
11SRCREV = "072130412196029bcc284e353023d81019a8daa7"
12
13S = "${WORKDIR}/git"
14
15DPAA_VER ?= "dpaa"
16export RTE_TARGET = "${ARCH}-${DPAA_VER}-linuxapp-gcc"
17
18EXTRA_OEMAKE += 'ARCH="${ARCH}" CROSS="${TARGET_PREFIX}" \
19 CPU_CFLAGS="--sysroot=${STAGING_DIR_HOST}" RTE_SDK="${S}" \
20 OPENSSL_PATH="${STAGING_DIR_HOST}" RTE_KERNELDIR="${STAGING_KERNEL_DIR}" \
21 RTE_KERNELDIR_OUT="${STAGING_KERNEL_BUILDDIR}" \
22'
23
24do_configure() {
25 export SYSROOT_DPDK=${PKG_CONFIG_SYSROOT_DIR}
26 ${S}/boot.sh
27 ${S}/configure --host aarch64-fsl-linux --with-dpdk=${SYSROOT_DPDK}/usr/share/${RTE_TARGET} --with-openssl=${SYSROOT_DPDK}/usr CFLAGS="-g -Wno-cast-align -Ofast"
28}
29
30do_compile() {
31 oe_runmake O="${RTE_TARGET}" T="${RTE_TARGET}"
32}
33
34do_install() {
35 install -d ${D}${bindir}/ovs-dpdk
36 cp -rf ${S}/ovsdb/ovsdb-tool ${D}${bindir}/ovs-dpdk
37 cp -rf ${S}/ovsdb/ovsdb-server ${D}${bindir}/ovs-dpdk
38 cp -rf ${S}/vswitchd/vswitch.ovsschema ${D}${bindir}/ovs-dpdk
39 cp -rf ${S}/vswitchd/ovs-vswitchd ${D}${bindir}/ovs-dpdk
40 cp -rf ${S}/utilities/ovs-vsctl ${D}${bindir}/ovs-dpdk
41 cp -rf ${S}/utilities/ovs-ofctl ${D}${bindir}/ovs-dpdk
42 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
43}
44
45ALLOW_EMPTY:${PN} = "1"
46INHIBIT_PACKAGE_STRIP = "1"
47PACKAGE_ARCH = "${MACHINE_ARCH}"
48COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
new file mode 100644
index 00000000..fb41b457
--- /dev/null
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.15.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "OVS DPDK"
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4
5DEPENDS = "dpdk python3-six-native coreutils-native autoconf-native automake-native"
6RDEPENDS:${PN} = "bash libcrypto libssl python3"
7
8inherit python3native pkgconfig
9
10SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ovs-dpdk;nobranch=1"
11SRCREV = "f2c0744d2f68c4cd2840d6e409d7b0520e4caf99"
12
13S = "${WORKDIR}/git"
14
15do_configure() {
16 export SYSROOT_DPDK=${PKG_CONFIG_SYSROOT_DIR}
17 ${S}/boot.sh
18 ${S}/configure --host aarch64-fsl-linux --with-dpdk=static --with-openssl=${SYSROOT_DPDK}/usr CFLAGS="-g -Wno-cast-align -Ofast"
19}
20
21do_install:append() {
22 install -d ${D}${bindir}/ovs-dpdk
23 cp -rf ${S}/ovsdb/ovsdb-tool ${D}${bindir}/ovs-dpdk
24 cp -rf ${S}/ovsdb/ovsdb-server ${D}${bindir}/ovs-dpdk
25 cp -rf ${S}/ovsdb/ovsdb-client ${D}${bindir}/ovs-dpdk
26 cp -rf ${S}/vswitchd/vswitch.ovsschema ${D}${bindir}/ovs-dpdk
27 cp -rf ${S}/vswitchd/ovs-vswitchd ${D}${bindir}/ovs-dpdk
28 cp -rf ${S}/utilities/ovs-vsctl ${D}${bindir}/ovs-dpdk
29 cp -rf ${S}/utilities/ovs-ofctl ${D}${bindir}/ovs-dpdk
30 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
31}
32
33ALLOW_EMPTY:${PN} = "1"
34INHIBIT_PACKAGE_STRIP = "1"
35PACKAGE_ARCH = "${MACHINE_ARCH}"
36COMPATIBLE_MACHINE = "(qoriq-arm64)"