summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorMeng Li <Meng.Li@windriver.com>2023-06-12 15:15:00 +0800
committerMeng Li <meng.li@windriver.com>2023-06-12 15:23:31 +0800
commit60a057fd292c35c4b0d63d38597576c0202a3c13 (patch)
tree4464aab87599cf991e0282c81bbdc61169f04ac5 /recipes-extended
parent0fd607426661798c071d93953c9b351f5785f690 (diff)
downloadmeta-freescale-60a057fd292c35c4b0d63d38597576c0202a3c13.tar.gz
meta-freescale: tsntool: remove redundant parameters from BIN_LDFLAGS
The recipe file has pass the same parameter(-Wl,-rpath-link,<lib path>) to Makefile, so remove redundant parameters from BIN_LDFLAGS. Signed-off-by: Meng Li <Meng.Li@windriver.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/tsntool/tsntool/0001-tsntool-remove-redundant-parameters-from-BIN_LDFLAGS.patch28
-rw-r--r--recipes-extended/tsntool/tsntool_git.bb6
2 files changed, 34 insertions, 0 deletions
diff --git a/recipes-extended/tsntool/tsntool/0001-tsntool-remove-redundant-parameters-from-BIN_LDFLAGS.patch b/recipes-extended/tsntool/tsntool/0001-tsntool-remove-redundant-parameters-from-BIN_LDFLAGS.patch
new file mode 100644
index 00000000..807f6a82
--- /dev/null
+++ b/recipes-extended/tsntool/tsntool/0001-tsntool-remove-redundant-parameters-from-BIN_LDFLAGS.patch
@@ -0,0 +1,28 @@
1From 2cf9a3f919317784e7cecdff6b632cdb2665c580 Mon Sep 17 00:00:00 2001
2From: Meng Li <Meng.Li@windriver.com>
3Date: Mon, 12 Jun 2023 15:17:21 +0800
4Subject: [PATCH] tsntool: remove redundant parameters from BIN_LDFLAGS
5
6The recipe file has pass the same parameter(-Wl,-rpath-link,<lib path>)
7to Makefile, so remove redundant parameters from BIN_LDFLAGS.
8
9Signed-off-by: Meng Li <Meng.Li@windriver.com>
10---
11 Makefile | 1 -
12 1 file changed, 1 deletion(-)
13
14diff --git a/Makefile b/Makefile
15index 0ba88b4..39a98c0 100644
16--- a/Makefile
17+++ b/Makefile
18@@ -16,7 +16,6 @@ BIN_CFLAGS += -Wall -Wextra -Wno-error=unused-parameter -Wno-error=sign-compare
19 BIN_CFLAGS += $(shell $(PKG_CONFIG) --cflags libnl-3.0 libnl-genl-3.0 libcjson) -Iinclude
20 BIN_LDFLAGS += -ltsn $(shell $(PKG_CONFIG) --libs libnl-3.0 libnl-genl-3.0 libcjson) -lpthread -lm -lrt
21 BIN_LDFLAGS += -lreadline -ltermcap -L.
22-BIN_LDFLAGS += -Wl,-rpath,$(shell pwd) # Compiled lib at local folder
23
24 BIN_SRC =
25 LIB_SRC =
26--
272.40.1
28
diff --git a/recipes-extended/tsntool/tsntool_git.bb b/recipes-extended/tsntool/tsntool_git.bb
index 6d1eb69c..2ad4a0c4 100644
--- a/recipes-extended/tsntool/tsntool_git.bb
+++ b/recipes-extended/tsntool/tsntool_git.bb
@@ -7,9 +7,15 @@ DEPENDS = "cjson libnl readline"
7 7
8inherit pkgconfig 8inherit pkgconfig
9 9
10FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
11
10SRC_URI = "git://github.com/nxp-qoriq/tsntool;protocol=https;nobranch=1" 12SRC_URI = "git://github.com/nxp-qoriq/tsntool;protocol=https;nobranch=1"
11SRCREV = "a0769e23304957a22f0cbeee6d1f547b20c3c21e" 13SRCREV = "a0769e23304957a22f0cbeee6d1f547b20c3c21e"
12 14
15SRC_URI:append = " \
16 file://0001-tsntool-remove-redundant-parameters-from-BIN_LDFLAGS.patch \
17"
18
13S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
14 20
15do_configure[depends] += "virtual/kernel:do_shared_workdir" 21do_configure[depends] += "virtual/kernel:do_shared_workdir"