summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-10 14:53:11 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commit60585d192208ca1cbebe1c7723ebb4c9d4649046 (patch)
tree375e00e251812788cef1e472d15ffed1b453f442 /recipes-extended
parent63d863c97d2770cab745bbd76734559bb6c8329a (diff)
downloadmeta-freescale-60585d192208ca1cbebe1c7723ebb4c9d4649046.tar.gz
pktgen-dpdk: Upgrade version to 3.6.6
include the following changes: b3d08bb - update version number and log 7c4187c - add new portInfo lua data 0c39019 - Cleanup build, add plugin support and meson build not working f6e9e33 - fix crash not resetting tty and other fixes 4199555 - Merge branch 'bug-fix' 3942af7 - fix Update to version 3.6.5 176df0a - fix ldflags order for lua lib 8c746d0 - minor message missing a word 5e29e43 - reorder the defines on the LDFLAGS line 6ed0bde - convert to DPDK network structs and fix offload code. 0e8ac37 - fix lua builds oni ubuntu 18.10 5b537c9 - change port command to use uint16_t 96776e5 - update .cfg file information b5133f1 - add page stats screen 5b883b2 - add more color to static info a0c5819 - convert all rte_delay_ms to rte_delay_us_sleep 83b1bfa - remove need for rte_timer_manage 4dcc2db - use faster timer routines then rte_timer_manage cca5864 - remove cycles.h header 0d5d9ab - change cli_use_timers routine to run rte_timer_manage 7283ba7 - remove crc-strip option b44f9e6 - remove init stats structure a82bbf5 - fix formatting with spaces 81623f1 - update readme, version and changelog Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_3.6.6.bb (renamed from recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb)15
1 files changed, 8 insertions, 7 deletions
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_3.6.6.bb
index 0a6d97de..29ed267e 100644
--- a/recipes-extended/pktgen-dpdk/pktgen-dpdk_git.bb
+++ b/recipes-extended/pktgen-dpdk/pktgen-dpdk_3.6.6.bb
@@ -1,23 +1,24 @@
1DESCRIPTION = "PKTGEN DPDK" 1DESCRIPTION = "PKTGEN DPDK"
2LICENSE = "BSD" 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8120b89a783571da3cb492c35ac6b1f9" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=30ac8fa65a07ea7cc1c7ee84e1c80294"
4 4
5DEPENDS += "libpcap dpdk" 5DEPENDS += "libpcap dpdk lua lua-native"
6 6
7SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=http;nobranch=1" 7SRC_URI = "git://dpdk.org/git/apps/pktgen-dpdk;protocol=https;nobranch=1 \
8SRCREV = "ffbe7becf8dd75fd7d46b97b10374531878cb9c5" 8"
9SRCREV = "b3d08bb3c29c999b261c7d74443da03079a012e9"
9 10
10S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
11 12
12DPAA_VER ?= "dpaa" 13DPAA_VER ?= "dpaa"
13export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc" 14export RTE_TARGET = "arm64-${DPAA_VER}-linuxapp-gcc"
14export RTE_SDK = "${RECIPE_SYSROOT}/usr/share" 15export RTE_SDK = "${RECIPE_SYSROOT}/usr/share/"
15 16
16EXTRA_OEMAKE += 'CC="${CC}" LD="${LD}" RTE_SDK="${RECIPE_SYSROOT}/usr/share" RTE_TARGET="arm64-${DPAA_VER}-linuxapp-gcc"' 17EXTRA_OEMAKE += 'CC="${CC}" LD="${LD}" RTE_SDK="${RECIPE_SYSROOT}/usr/share/" RTE_TARGET="arm64-${DPAA_VER}-linuxapp-gcc"'
17 18
18do_compile() { 19do_compile() {
19 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS 20 unset LDFLAGS TARGET_LDFLAGS BUILD_LDFLAGS
20 oe_runmake 21 oe_runmake EXTRA_CFLAGS="${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS} -I${STAGING_INCDIR} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}"
21} 22}
22 23
23do_install() { 24do_install() {