summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-08-02 11:01:05 -0700
committerKhem Raj <raj.khem@gmail.com>2021-08-12 10:08:24 -0700
commit59d36c9832702989bfcca8a5af29fb2dff01efcc (patch)
treeb2b07d98cb22bc5241cde7403b6a15d99821318e /recipes-extended
parent72f59d35816cd2be6159013e4d96d03abf7f1c4b (diff)
downloadmeta-freescale-59d36c9832702989bfcca8a5af29fb2dff01efcc.tar.gz
layer: Convert to new override syntax
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/crconf/crconf_git.bb2
-rw-r--r--recipes-extended/dpdk/dpdk.inc30
-rw-r--r--recipes-extended/dpdk/dpdk_19.11-20.12.bb2
-rw-r--r--recipes-extended/ipc-ust/ipc-ust_git.bb10
-rw-r--r--recipes-extended/jailhouse/jailhouse_0.12.bb16
-rw-r--r--recipes-extended/libpkcs11/libpkcs11_git.bb4
-rw-r--r--recipes-extended/merge-files/merge-files_1.0.bb6
-rw-r--r--recipes-extended/odp/odp-counters_git.bb2
-rw-r--r--recipes-extended/odp/odp-module_git.bb4
-rw-r--r--recipes-extended/odp/odp.inc2
-rw-r--r--recipes-extended/odp/odp_git.bb26
-rw-r--r--recipes-extended/ofp/ofp_git.bb4
-rw-r--r--recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb4
-rw-r--r--recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb2
-rw-r--r--recipes-extended/procps/procps_%.bbappend2
-rw-r--r--recipes-extended/secure-obj/secure-obj.inc6
-rw-r--r--recipes-extended/secure-obj/secure-obj_git.bb12
-rw-r--r--recipes-extended/testfloat/testfloat_2a.bb4
-rw-r--r--recipes-extended/tsntool/tsntool_git.bb6
19 files changed, 72 insertions, 72 deletions
diff --git a/recipes-extended/crconf/crconf_git.bb b/recipes-extended/crconf/crconf_git.bb
index f8f88d20..1727888a 100644
--- a/recipes-extended/crconf/crconf_git.bb
+++ b/recipes-extended/crconf/crconf_git.bb
@@ -14,4 +14,4 @@ do_install () {
14 oe_runmake install DESTDIR=${D} 14 oe_runmake install DESTDIR=${D}
15} 15}
16 16
17FILES_${PN} += "/share/man/* ${libdir}/* ${sbindir}/*" 17FILES:${PN} += "/share/man/* ${libdir}/* ${sbindir}/*"
diff --git a/recipes-extended/dpdk/dpdk.inc b/recipes-extended/dpdk/dpdk.inc
index 61c02ae7..f4c932ea 100644
--- a/recipes-extended/dpdk/dpdk.inc
+++ b/recipes-extended/dpdk/dpdk.inc
@@ -1,25 +1,25 @@
1DESCRIPTION = "Data Plane Development Kit" 1DESCRIPTION = "Data Plane Development Kit"
2HOMEPAGE = "http://dpdk.org" 2HOMEPAGE = "http://dpdk.org"
3 3
4RDEPENDS_${PN} += "python3-core" 4RDEPENDS:${PN} += "python3-core"
5DEPENDS = "virtual/kernel openssl" 5DEPENDS = "virtual/kernel openssl"
6DEPENDS_append_x86-64 = " numactl" 6DEPENDS:append:x86-64 = " numactl"
7do_configure[depends] += "virtual/kernel:do_shared_workdir" 7do_configure[depends] += "virtual/kernel:do_shared_workdir"
8 8
9inherit module 9inherit module
10 10
11COMPATIBLE_HOST = '(aarch64|arm|i.86|x86_64).*-linux' 11COMPATIBLE_HOST = '(aarch64|arm|i.86|x86_64).*-linux'
12COMPATIBLE_HOST_libc-musl = 'null' 12COMPATIBLE_HOST:libc-musl = 'null'
13COMPATIBLE_HOST_armv4 = 'null' 13COMPATIBLE_HOST:armv4 = 'null'
14COMPATIBLE_HOST_armv5 = 'null' 14COMPATIBLE_HOST:armv5 = 'null'
15COMPATIBLE_HOST_armv6 = 'null' 15COMPATIBLE_HOST:armv6 = 'null'
16 16
17COMPATIBLE_MACHINE = "(imx|qoriq)" 17COMPATIBLE_MACHINE = "(imx|qoriq)"
18 18
19DPDK_RTE_TARGET_x86-64 = "x86_64-native-linuxapp-gcc" 19DPDK_RTE_TARGET:x86-64 = "x86_64-native-linuxapp-gcc"
20DPDK_RTE_TARGET_x86 = "i686-native-linuxapp-gcc" 20DPDK_RTE_TARGET:x86 = "i686-native-linuxapp-gcc"
21DPDK_RTE_TARGET_armv7a = "${ARCH}-armv7a-linuxapp-gcc" 21DPDK_RTE_TARGET:armv7a = "${ARCH}-armv7a-linuxapp-gcc"
22DPDK_RTE_TARGET_armv7ve = "${ARCH}-armv7a-linuxapp-gcc" 22DPDK_RTE_TARGET:armv7ve = "${ARCH}-armv7a-linuxapp-gcc"
23DPDK_RTE_TARGET ?= "${ARCH}-dpaa-linuxapp-gcc" 23DPDK_RTE_TARGET ?= "${ARCH}-dpaa-linuxapp-gcc"
24 24
25export RTE_TARGET = "${DPDK_RTE_TARGET}" 25export RTE_TARGET = "${DPDK_RTE_TARGET}"
@@ -93,13 +93,13 @@ do_install () {
93 93
94PACKAGES += "${PN}-examples" 94PACKAGES += "${PN}-examples"
95 95
96FILES_${PN}-dbg += " \ 96FILES:${PN}-dbg += " \
97 ${datadir}/dpdk/.debug \ 97 ${datadir}/dpdk/.debug \
98 ${datadir}/dpdk/examples/*/.debug \ 98 ${datadir}/dpdk/examples/*/.debug \
99 " 99 "
100FILES_${PN}-staticdev += "${datadir}/dpdk/cmdif/lib/*.a \ 100FILES:${PN}-staticdev += "${datadir}/dpdk/cmdif/lib/*.a \
101" 101"
102FILES_${PN}-dev += " \ 102FILES:${PN}-dev += " \
103 ${datadir}/dpdk/${RTE_TARGET}/.config \ 103 ${datadir}/dpdk/${RTE_TARGET}/.config \
104 ${includedir} \ 104 ${includedir} \
105 ${includedir}/exec-env \ 105 ${includedir}/exec-env \
@@ -109,11 +109,11 @@ FILES_${PN}-dev += " \
109 ${datadir}/dpdk/mk \ 109 ${datadir}/dpdk/mk \
110 " 110 "
111 111
112FILES_${PN} += " ${datadir}/ \ 112FILES:${PN} += " ${datadir}/ \
113 ${prefix}/sbin/ \ 113 ${prefix}/sbin/ \
114 ${prefix}/bin/ \ 114 ${prefix}/bin/ \
115 ${libdir}/ \ 115 ${libdir}/ \
116 " 116 "
117FILES_${PN}-examples += " \ 117FILES:${PN}-examples += " \
118 ${datadir}/examples/* \ 118 ${datadir}/examples/* \
119 " 119 "
diff --git a/recipes-extended/dpdk/dpdk_19.11-20.12.bb b/recipes-extended/dpdk/dpdk_19.11-20.12.bb
index 426713c2..37582124 100644
--- a/recipes-extended/dpdk/dpdk_19.11-20.12.bb
+++ b/recipes-extended/dpdk/dpdk_19.11-20.12.bb
@@ -13,7 +13,7 @@ SRCREV = "7071c27f6f5aefb57de1cffab3484707b1e82e2b"
13 13
14include dpdk.inc 14include dpdk.inc
15 15
16do_install_append () { 16do_install:append () {
17 # Remove the unneeded dir 17 # Remove the unneeded dir
18 rm -rf ${D}/${datadir}/${RTE_TARGET}/app 18 rm -rf ${D}/${datadir}/${RTE_TARGET}/app
19} 19}
diff --git a/recipes-extended/ipc-ust/ipc-ust_git.bb b/recipes-extended/ipc-ust/ipc-ust_git.bb
index df496c28..f307816e 100644
--- a/recipes-extended/ipc-ust/ipc-ust_git.bb
+++ b/recipes-extended/ipc-ust/ipc-ust_git.bb
@@ -40,12 +40,12 @@ do_install () {
40 install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib 40 install ${S}/fsl_shm/lib/*.h ${D}${includedir}/ipc/fsl_shm/lib
41} 41}
42 42
43FILES_${PN} += "${base_libdir}/*.so /ipc/*" 43FILES:${PN} += "${base_libdir}/*.so /ipc/*"
44FILES_${PN}-dev = "${includedir}" 44FILES:${PN}-dev = "${includedir}"
45FILES_${PN}-dbg += "/ipc/.debug" 45FILES:${PN}-dbg += "/ipc/.debug"
46 46
47INSANE_SKIP_${PN} += "file-rdeps" 47INSANE_SKIP:${PN} += "file-rdeps"
48INSANE_SKIP_${PN}-dev += "dev-elf" 48INSANE_SKIP:${PN}-dev += "dev-elf"
49 49
50COMPATIBLE_MACHINE = "(b4860qds|b4420qds)" 50COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"
51PACKAGE_ARCH = "${MACHINE_ARCH}" 51PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-extended/jailhouse/jailhouse_0.12.bb b/recipes-extended/jailhouse/jailhouse_0.12.bb
index c49d7f5b..43b4cdf5 100644
--- a/recipes-extended/jailhouse/jailhouse_0.12.bb
+++ b/recipes-extended/jailhouse/jailhouse_0.12.bb
@@ -39,9 +39,9 @@ CELLCONF_DIR ?= "${JH_DATADIR}/configs"
39INMATES_DIR ?= "${JH_DATADIR}/inmates" 39INMATES_DIR ?= "${JH_DATADIR}/inmates"
40 40
41JH_CONFIG ?= "${S}/ci/jailhouse-config-x86.h" 41JH_CONFIG ?= "${S}/ci/jailhouse-config-x86.h"
42JH_CONFIG_x86 ?= "${S}/ci/jailhouse-config-x86.h" 42JH_CONFIG:x86 ?= "${S}/ci/jailhouse-config-x86.h"
43JH_CONFIG_x86-64 ?= "${S}/ci/jailhouse-config-x86.h" 43JH_CONFIG:x86-64 ?= "${S}/ci/jailhouse-config-x86.h"
44JH_CONFIG_arm ?= "${S}/ci/jailhouse-config-banana-pi.h" 44JH_CONFIG:arm ?= "${S}/ci/jailhouse-config-banana-pi.h"
45 45
46do_configure() { 46do_configure() {
47 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ]; 47 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ];
@@ -101,22 +101,22 @@ do_install() {
101 101
102PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse" 102PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse"
103 103
104FILES_${PN} += "${nonarch_base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}" 104FILES:${PN} += "${nonarch_base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
105FILES_pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}/pyjailhouse" 105FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}/pyjailhouse"
106 106
107RDEPENDS_${PN} += " \ 107RDEPENDS:${PN} += " \
108 python3-curses \ 108 python3-curses \
109 python3-datetime \ 109 python3-datetime \
110 python3-mmap \ 110 python3-mmap \
111" 111"
112 112
113RDEPENDS_pyjailhouse = " \ 113RDEPENDS:pyjailhouse = " \
114 python3-core \ 114 python3-core \
115 python3-ctypes \ 115 python3-ctypes \
116 python3-fcntl \ 116 python3-fcntl \
117 python3-shell \ 117 python3-shell \
118" 118"
119 119
120INSANE_SKIP_${PN} = "ldflags" 120INSANE_SKIP:${PN} = "ldflags"
121 121
122COMPATIBLE_MACHINE = "(mx8m)" 122COMPATIBLE_MACHINE = "(mx8m)"
diff --git a/recipes-extended/libpkcs11/libpkcs11_git.bb b/recipes-extended/libpkcs11/libpkcs11_git.bb
index 30f33a20..5496b09c 100644
--- a/recipes-extended/libpkcs11/libpkcs11_git.bb
+++ b/recipes-extended/libpkcs11/libpkcs11_git.bb
@@ -34,6 +34,6 @@ do_install(){
34} 34}
35 35
36PARALLEL_MAKE = "" 36PARALLEL_MAKE = ""
37INSANE_SKIP_${PN} = "ldflags dev-deps" 37INSANE_SKIP:${PN} = "ldflags dev-deps"
38INSANE_SKIP_${PN}-dev = "ldflags dev-elf" 38INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
39COMPATIBLE_MACHINE = "(qoriq-arm64)" 39COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/merge-files/merge-files_1.0.bb b/recipes-extended/merge-files/merge-files_1.0.bb
index 6fe5b637..5b3ca7ed 100644
--- a/recipes-extended/merge-files/merge-files_1.0.bb
+++ b/recipes-extended/merge-files/merge-files_1.0.bb
@@ -17,6 +17,6 @@ do_install () {
17do_configure[noexec] = "1" 17do_configure[noexec] = "1"
18do_compile[noexec] = "1" 18do_compile[noexec] = "1"
19 19
20FILES_${PN} = "/*" 20FILES:${PN} = "/*"
21ALLOW_EMPTY_${PN} = "1" 21ALLOW_EMPTY:${PN} = "1"
22INSANE_SKIP_${PN} = "debug-files dev-so" 22INSANE_SKIP:${PN} = "debug-files dev-so"
diff --git a/recipes-extended/odp/odp-counters_git.bb b/recipes-extended/odp/odp-counters_git.bb
index 860dd5fa..9d88ea43 100644
--- a/recipes-extended/odp/odp-counters_git.bb
+++ b/recipes-extended/odp/odp-counters_git.bb
@@ -2,7 +2,7 @@ require odp.inc
2 2
3inherit module 3inherit module
4 4
5do_compile_prepend () { 5do_compile:prepend () {
6 export KERNEL_PATH="${STAGING_KERNEL_DIR}" 6 export KERNEL_PATH="${STAGING_KERNEL_DIR}"
7 export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}" 7 export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}"
8 cd ${S}/test/debug/perf_counters 8 cd ${S}/test/debug/perf_counters
diff --git a/recipes-extended/odp/odp-module_git.bb b/recipes-extended/odp/odp-module_git.bb
index 46b89654..0748e5bf 100644
--- a/recipes-extended/odp/odp-module_git.bb
+++ b/recipes-extended/odp/odp-module_git.bb
@@ -2,7 +2,7 @@ require odp.inc
2 2
3inherit module 3inherit module
4 4
5do_compile_prepend () { 5do_compile:prepend () {
6 export KERNEL_PATH="${STAGING_KERNEL_DIR}" 6 export KERNEL_PATH="${STAGING_KERNEL_DIR}"
7 export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}" 7 export KERNEL_CFG_PATH="${STAGING_KERNEL_BUILDDIR}"
8 cd ${S}/kern 8 cd ${S}/kern
@@ -13,4 +13,4 @@ do_install () {
13 install -m 755 ${S}/kern/odpfsl_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/odp 13 install -m 755 ${S}/kern/odpfsl_kni.ko ${D}/lib/modules/${KERNEL_VERSION}/odp
14} 14}
15 15
16PKG_${PN} = "kernel-module-${PN}" 16PKG:${PN} = "kernel-module-${PN}"
diff --git a/recipes-extended/odp/odp.inc b/recipes-extended/odp/odp.inc
index 129f77ae..d1e10b0f 100644
--- a/recipes-extended/odp/odp.inc
+++ b/recipes-extended/odp/odp.inc
@@ -6,7 +6,7 @@ SECTION = "console/network"
6LICENSE = "BSD-3-Clause" 6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=ca6103dc75397fb6bec596187d6b7829" 7LIC_FILES_CHKSUM = "file://LICENSE;md5=ca6103dc75397fb6bec596187d6b7829"
8 8
9FILESEXTRAPATHS_prepend := "${THISDIR}/odp:" 9FILESEXTRAPATHS:prepend := "${THISDIR}/odp:"
10 10
11SRC_URI = " \ 11SRC_URI = " \
12git://source.codeaurora.org/external/qoriq/qoriq-components/odp;nobranch=1 \ 12git://source.codeaurora.org/external/qoriq/qoriq-components/odp;nobranch=1 \
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb
index 00575e24..9c94e432 100644
--- a/recipes-extended/odp/odp_git.bb
+++ b/recipes-extended/odp/odp_git.bb
@@ -6,17 +6,17 @@ PACKAGE_ARCH = "${MACHINE_ARCH}"
6 6
7DEPENDS = "openssl cunit libxml2" 7DEPENDS = "openssl cunit libxml2"
8 8
9RDEPENDS_${PN} = "bash libcrypto libssl odp-module odp-counters" 9RDEPENDS:${PN} = "bash libcrypto libssl odp-module odp-counters"
10 10
11ODP_SOC ?= "" 11ODP_SOC ?= ""
12ODP_SOC_ls1043ardb = "LS1043" 12ODP_SOC:ls1043ardb = "LS1043"
13ODP_SOC_ls1046ardb = "LS1046" 13ODP_SOC:ls1046ardb = "LS1046"
14ODP_PLATFORM ?= "linux-dpaa2" 14ODP_PLATFORM ?= "linux-dpaa2"
15ODP_BUILD_TYPE ?= "ls2088" 15ODP_BUILD_TYPE ?= "ls2088"
16ODP_BUILD_TYPE_ls1043ardb = "ls1043" 16ODP_BUILD_TYPE:ls1043ardb = "ls1043"
17ODP_BUILD_TYPE_ls1046ardb = "ls1046" 17ODP_BUILD_TYPE:ls1046ardb = "ls1046"
18ODP_BUILD_TYPE_ls2080ardb = "ls2080" 18ODP_BUILD_TYPE:ls2080ardb = "ls2080"
19ODP_BUILD_TYPE_ls1088ardb = "ls1088" 19ODP_BUILD_TYPE:ls1088ardb = "ls1088"
20 20
21EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \ 21EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \
22 --enable-test-vald \ 22 --enable-test-vald \
@@ -34,17 +34,17 @@ CFLAGS += "-Wno-format-truncation -Wno-maybe-uninitialized -Wno-implicit-fallthr
34 34
35PACKAGECONFIG[perf] = "--enable-test-perf,,," 35PACKAGECONFIG[perf] = "--enable-test-perf,,,"
36 36
37do_configure_prepend () { 37do_configure:prepend () {
38 export SOC=${ODP_SOC} 38 export SOC=${ODP_SOC}
39 ${S}/bootstrap 39 ${S}/bootstrap
40} 40}
41 41
42do_compile_prepend () { 42do_compile:prepend () {
43 export SOC=${ODP_SOC} 43 export SOC=${ODP_SOC}
44 export ARCH=${TUNE_ARCH} 44 export ARCH=${TUNE_ARCH}
45} 45}
46 46
47do_install_append () { 47do_install:append () {
48 install -d ${D}${includedir}/odp/kni 48 install -d ${D}${includedir}/odp/kni
49 install -d ${D}${includedir}/odp/kern 49 install -d ${D}${includedir}/odp/kern
50 install -d ${D}${includedir}/odp/flib/mc 50 install -d ${D}${includedir}/odp/flib/mc
@@ -58,6 +58,6 @@ do_install_append () {
58 sed -i -e 's#platform/linux-dpaa2/##g' ${D}${includedir}/odp/kern/*.h 58 sed -i -e 's#platform/linux-dpaa2/##g' ${D}${includedir}/odp/kern/*.h
59} 59}
60 60
61FILES_${PN}-staticdev += "${datadir}/opendataplane/*.la" 61FILES:${PN}-staticdev += "${datadir}/opendataplane/*.la"
62FILES_${PN} += "/usr/odp/bin /usr/odp/scripts /usr/odp/debug /usr/odp/test/validation /usr/odp/test/performance /usr/odp/test/miscellaneous /usr/odp/test/api_test" 62FILES:${PN} += "/usr/odp/bin /usr/odp/scripts /usr/odp/debug /usr/odp/test/validation /usr/odp/test/performance /usr/odp/test/miscellaneous /usr/odp/test/api_test"
63FILES_${PN}-dbg += "/usr/odp/bin/.debug /usr/odp/debug/.debug /usr/odp/test/validation/.debug /usr/odp/test/performance/.debug /usr/odp/test/miscellaneous/.debug /usr/odp/test/api_test/.debug" 63FILES:${PN}-dbg += "/usr/odp/bin/.debug /usr/odp/debug/.debug /usr/odp/test/validation/.debug /usr/odp/test/performance/.debug /usr/odp/test/miscellaneous/.debug /usr/odp/test/api_test/.debug"
diff --git a/recipes-extended/ofp/ofp_git.bb b/recipes-extended/ofp/ofp_git.bb
index c76eafd7..ec7328c8 100644
--- a/recipes-extended/ofp/ofp_git.bb
+++ b/recipes-extended/ofp/ofp_git.bb
@@ -32,6 +32,6 @@ do_configure () {
32 ${S}/configure ${EXTRA_OECONF} 32 ${S}/configure ${EXTRA_OECONF}
33} 33}
34 34
35FILES_${PN} += "/usr/ofp/bin" 35FILES:${PN} += "/usr/ofp/bin"
36FILES_${PN}-dbg += "/usr/ofp/bin/.debug" 36FILES:${PN}-dbg += "/usr/ofp/bin/.debug"
37COMPATIBLE_MACHINE = "(ls2088a|ls1088a)" 37COMPATIBLE_MACHINE = "(ls2088a|ls1088a)"
diff --git a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
index 9e817579..f9d32773 100644
--- a/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
+++ b/recipes-extended/ovs-dpdk/ovs-dpdk_2.13.0.bb
@@ -3,7 +3,7 @@ LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab" 3LIC_FILES_CHKSUM = "file://LICENSE;md5=1ce5d23a6429dff345518758f13aaeab"
4 4
5DEPENDS = "dpdk python3-six-native coreutils-native" 5DEPENDS = "dpdk python3-six-native coreutils-native"
6RDEPENDS_${PN} = "bash libcrypto libssl python3" 6RDEPENDS:${PN} = "bash libcrypto libssl python3"
7 7
8inherit python3native 8inherit python3native
9 9
@@ -42,7 +42,7 @@ do_install() {
42 chmod 777 -R ${D}${bindir}/ovs-dpdk/* 42 chmod 777 -R ${D}${bindir}/ovs-dpdk/*
43} 43}
44 44
45ALLOW_EMPTY_${PN} = "1" 45ALLOW_EMPTY:${PN} = "1"
46INHIBIT_PACKAGE_STRIP = "1" 46INHIBIT_PACKAGE_STRIP = "1"
47PACKAGE_ARCH = "${MACHINE_ARCH}" 47PACKAGE_ARCH = "${MACHINE_ARCH}"
48COMPATIBLE_MACHINE = "(qoriq-arm64)" 48COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb b/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
index f3a73c35..6a039129 100644
--- a/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
+++ b/recipes-extended/pktgen-dpdk/pktgen-dpdk_19.12.0.bb
@@ -26,7 +26,7 @@ do_install() {
26 cp -f ${S}/Pktgen.lua ${D}${bindir}/ 26 cp -f ${S}/Pktgen.lua ${D}${bindir}/
27} 27}
28 28
29INSANE_SKIP_${PN} = "ldflags" 29INSANE_SKIP:${PN} = "ldflags"
30INHIBIT_PACKAGE_STRIP = "1" 30INHIBIT_PACKAGE_STRIP = "1"
31PACKAGE_ARCH = "${MACHINE_ARCH}" 31PACKAGE_ARCH = "${MACHINE_ARCH}"
32PARALLEL_MAKE = "" 32PARALLEL_MAKE = ""
diff --git a/recipes-extended/procps/procps_%.bbappend b/recipes-extended/procps/procps_%.bbappend
index face0ccc..43fb349b 100644
--- a/recipes-extended/procps/procps_%.bbappend
+++ b/recipes-extended/procps/procps_%.bbappend
@@ -1,4 +1,4 @@
1do_install_append_qoriq-ppc() { 1do_install:append:qoriq-ppc() {
2 for keyword in \ 2 for keyword in \
3 net.ipv4.conf.default.rp_filter \ 3 net.ipv4.conf.default.rp_filter \
4 net.ipv4.conf.all.rp_filter \ 4 net.ipv4.conf.all.rp_filter \
diff --git a/recipes-extended/secure-obj/secure-obj.inc b/recipes-extended/secure-obj/secure-obj.inc
index 8a62d9cb..55f20ed5 100644
--- a/recipes-extended/secure-obj/secure-obj.inc
+++ b/recipes-extended/secure-obj/secure-obj.inc
@@ -2,7 +2,7 @@ DESCRIPTION = "Secure Object"
2LICENSE = "BSD" 2LICENSE = "BSD"
3 3
4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq" 4DEPENDS = "openssl optee-os-qoriq optee-client-qoriq"
5RDEPENDS_${PN} = "bash libcrypto libssl" 5RDEPENDS:${PN} = "bash libcrypto libssl"
6 6
7DEPENDS += "python3-pycryptodomex-native" 7DEPENDS += "python3-pycryptodomex-native"
8 8
@@ -20,9 +20,9 @@ export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
20 20
21EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' 21EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
22 22
23ALLOW_EMPTY_${PN} = "1" 23ALLOW_EMPTY:${PN} = "1"
24INHIBIT_PACKAGE_STRIP = "1" 24INHIBIT_PACKAGE_STRIP = "1"
25PARALLEL_MAKE = "" 25PARALLEL_MAKE = ""
26INSANE_SKIP_${PN} = "ldflags" 26INSANE_SKIP:${PN} = "ldflags"
27COMPATIBLE_MACHINE = "(qoriq-arm64)" 27COMPATIBLE_MACHINE = "(qoriq-arm64)"
28DEBUG_BUILD = "1" 28DEBUG_BUILD = "1"
diff --git a/recipes-extended/secure-obj/secure-obj_git.bb b/recipes-extended/secure-obj/secure-obj_git.bb
index 2d723738..1fd1fea3 100644
--- a/recipes-extended/secure-obj/secure-obj_git.bb
+++ b/recipes-extended/secure-obj/secure-obj_git.bb
@@ -4,15 +4,15 @@ LIC_FILES_CHKSUM = "file://README;md5=82b72e88f23cded9dd23f0fb1790b8d2"
4 4
5S = "${WORKDIR}/git" 5S = "${WORKDIR}/git"
6 6
7RDEPENDS_{PN} += "secure-obj-module" 7RDEPENDS:{PN} += "secure-obj-module"
8 8
9WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}" 9WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
10export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/" 10export SECURE_STORAGE_PATH = "${S}/secure_storage_ta/ta/"
11export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr" 11export OPTEE_CLIENT_EXPORT = "${RECIPE_SYSROOT}/usr"
12export CROSS_COMPILE_HOST = "${CROSS_COMPILE}" 12export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
13export CROSS_COMPILE_TA = "${CROSS_COMPILE}" 13export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
14ARCH_qoriq-arm64 = "aarch64" 14ARCH:qoriq-arm64 = "aarch64"
15ARCH_qoriq-arm = "arm" 15ARCH:qoriq-arm = "arm"
16 16
17do_compile() { 17do_compile() {
18 unset LDFLAGS 18 unset LDFLAGS
@@ -41,6 +41,6 @@ do_install() {
41 rm -rf ${D}${bindir}/test 41 rm -rf ${D}${bindir}/test
42} 42}
43 43
44FILES_${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines" 44FILES:${PN} += "${base_libdir}/optee_armtz ${libdir}/${ARCH}-linux-gnu/openssl-1.0.0/engines"
45INSANE_SKIP_${PN} = "dev-deps ldflags" 45INSANE_SKIP:${PN} = "dev-deps ldflags"
46INSANE_SKIP_${PN}-dev = "ldflags dev-elf" 46INSANE_SKIP:${PN}-dev = "ldflags dev-elf"
diff --git a/recipes-extended/testfloat/testfloat_2a.bb b/recipes-extended/testfloat/testfloat_2a.bb
index 800cef3d..4ed2ceb3 100644
--- a/recipes-extended/testfloat/testfloat_2a.bb
+++ b/recipes-extended/testfloat/testfloat_2a.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://testfloat/testfloat.txt;beginline=87;endline=95;md5=b
6SRC_URI = " http://www.jhauser.us/arithmetic/TestFloat-2a.tar.Z;name=TestFloat \ 6SRC_URI = " http://www.jhauser.us/arithmetic/TestFloat-2a.tar.Z;name=TestFloat \
7 http://www.jhauser.us/arithmetic/SoftFloat-2b.tar.Z;name=SoftFloat \ 7 http://www.jhauser.us/arithmetic/SoftFloat-2b.tar.Z;name=SoftFloat \
8 " 8 "
9SRC_URI_append_qoriq-ppc = " file://SoftFloat-powerpc-1.patch \ 9SRC_URI:append:qoriq-ppc = " file://SoftFloat-powerpc-1.patch \
10 file://TestFloat-powerpc-E500v2-SPE-1.patch \ 10 file://TestFloat-powerpc-E500v2-SPE-1.patch \
11 file://Yocto-replace-COMPILE_PREFIX-gcc.patch \ 11 file://Yocto-replace-COMPILE_PREFIX-gcc.patch \
12 " 12 "
@@ -40,6 +40,6 @@ do_install(){
40 install testfloat/powerpc-linux-gcc/testsoftfloat ${D}/${bindir} 40 install testfloat/powerpc-linux-gcc/testsoftfloat ${D}/${bindir}
41} 41}
42 42
43COMPATIBLE_HOST_e500v2 = ".*" 43COMPATIBLE_HOST:e500v2 = ".*"
44COMPATIBLE_HOST ?= "(none)" 44COMPATIBLE_HOST ?= "(none)"
45 45
diff --git a/recipes-extended/tsntool/tsntool_git.bb b/recipes-extended/tsntool/tsntool_git.bb
index 8ef79d27..f4f10938 100644
--- a/recipes-extended/tsntool/tsntool_git.bb
+++ b/recipes-extended/tsntool/tsntool_git.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
14 14
15do_configure[depends] += "virtual/kernel:do_shared_workdir" 15do_configure[depends] += "virtual/kernel:do_shared_workdir"
16 16
17do_compile_prepend() { 17do_compile:prepend() {
18 mkdir -p ${S}/include/linux 18 mkdir -p ${S}/include/linux
19 cp -r ${STAGING_KERNEL_DIR}/include/uapi/linux/tsn.h ${S}/include/linux 19 cp -r ${STAGING_KERNEL_DIR}/include/uapi/linux/tsn.h ${S}/include/linux
20} 20}
@@ -25,7 +25,7 @@ do_install() {
25} 25}
26 26
27PACKAGES = "${PN}-dbg ${PN}" 27PACKAGES = "${PN}-dbg ${PN}"
28FILES_${PN} = "${libdir}/libtsn.so ${bindir}/*" 28FILES:${PN} = "${libdir}/libtsn.so ${bindir}/*"
29INSANE_SKIP_${PN} += "file-rdeps rpaths dev-so" 29INSANE_SKIP:${PN} += "file-rdeps rpaths dev-so"
30COMPATIBLE_MACHINE = "(qoriq)" 30COMPATIBLE_MACHINE = "(qoriq)"
31PARALLEL_MAKE = "" 31PARALLEL_MAKE = ""