summaryrefslogtreecommitdiffstats
path: root/recipes-extended
diff options
context:
space:
mode:
authorRicardo Salveti <ricardo@foundries.io>2022-12-07 20:05:05 -0300
committerRicardo Salveti <ricardo@foundries.io>2022-12-07 22:16:09 -0300
commit0bd7408bc48a330adb6731119e8d57bf4911b1fe (patch)
tree49056f58b864780529d0dda85e4ce45b6611b43c /recipes-extended
parentdc92023272e77c374ff6cd822ed8438ce3580a2d (diff)
downloadmeta-freescale-0bd7408bc48a330adb6731119e8d57bf4911b1fe.tar.gz
jailhouse: update to lf-5.15.52_2.1.0
Update jailhouse to the NXP lf-5.15.52_2.1.0 release, and clean up the packaging logic to align with the latest release. Packaging changes: - Drop build instructions for tools as that is now built as part of the main Makefile - Drop JH_CONFIG and related tools variables as they are not required - Change do_compile and do_install to prepend to allow the logic from setuptools3 to be executed (and package pyjailhouse properly) - Drop kernel from PACKAGE_BEFORE_PN, as it wasn't really used in the end, and doesn't work correctly with usrmerge. Prefer removing libdir that gets appended by setuptools3 for module split to work correctly with and without usrmerge. - Update FILES for pyjailhouse to include all the python related files produced by the build Signed-off-by: Ricardo Salveti <ricardo@foundries.io>
Diffstat (limited to 'recipes-extended')
-rw-r--r--recipes-extended/jailhouse/jailhouse_0.12.bb37
1 files changed, 9 insertions, 28 deletions
diff --git a/recipes-extended/jailhouse/jailhouse_0.12.bb b/recipes-extended/jailhouse/jailhouse_0.12.bb
index 111a2c6b..b031b13c 100644
--- a/recipes-extended/jailhouse/jailhouse_0.12.bb
+++ b/recipes-extended/jailhouse/jailhouse_0.12.bb
@@ -13,11 +13,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9fa7f895f96bde2d47fd5b7d95b6ba4d \
13 file://driver/jailhouse.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \ 13 file://driver/jailhouse.h;beginline=9;endline=36;md5=2825581c1666c44a17955dc574cfbfb3 \
14" 14"
15 15
16SRCBRANCH = "lf-5.15.32_2.0.0" 16SRCBRANCH = "lf-5.15.52_2.1.0"
17SRCREV = "fb37d16f7f9df172877fc76631e4fccefceda29c" 17SRCREV = "da1b37baf48295bf1a4f25661220506f5bb948f2"
18 18
19SRC_URI = "git://source.codeaurora.org/external/imx/imx-jailhouse.git;protocol=ssh;branch=${SRCBRANCH} \ 19SRC_URI = "git://github.com/nxp-imx/imx-jailhouse.git;protocol=https;branch=${SRCBRANCH}"
20"
21 20
22DEPENDS = " \ 21DEPENDS = " \
23 make-native \ 22 make-native \
@@ -37,11 +36,6 @@ CELL_DIR ?= "${JH_DATADIR}/cells"
37CELLCONF_DIR ?= "${JH_DATADIR}/configs" 36CELLCONF_DIR ?= "${JH_DATADIR}/configs"
38INMATES_DIR ?= "${JH_DATADIR}/inmates" 37INMATES_DIR ?= "${JH_DATADIR}/inmates"
39 38
40JH_CONFIG ?= "${S}/ci/jailhouse-config-x86.h"
41JH_CONFIG:x86 ?= "${S}/ci/jailhouse-config-x86.h"
42JH_CONFIG:x86-64 ?= "${S}/ci/jailhouse-config-x86.h"
43JH_CONFIG:arm ?= "${S}/ci/jailhouse-config-banana-pi.h"
44
45do_configure() { 39do_configure() {
46 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ]; 40 if [ -d ${STAGING_DIR_HOST}/${CELLCONF_DIR} ];
47 then 41 then
@@ -49,29 +43,14 @@ do_configure() {
49 fi 43 fi
50} 44}
51 45
52USER_SPACE_CFLAGS = '${CFLAGS} -DLIBEXECDIR=\\\"${libexecdir}\\\" \ 46do_compile:prepend() {
53 -DJAILHOUSE_VERSION=\\\"$JAILHOUSE_VERSION\\\" \
54 -Wall -Wextra -Wmissing-declarations -Wmissing-prototypes -Werror \
55 -I../driver'
56
57TOOLS_SRC_DIR = "${S}/tools"
58TOOLS_OBJ_DIR = "${S}/tools"
59
60do_compile() {
61 unset LDFLAGS 47 unset LDFLAGS
62 oe_runmake V=1 CC="${CC}" \ 48 oe_runmake V=1 CC="${CC}" \
63 ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} \ 49 ARCH=${JH_ARCH} CROSS_COMPILE=${TARGET_PREFIX} \
64 KDIR=${STAGING_KERNEL_BUILDDIR} 50 KDIR=${STAGING_KERNEL_BUILDDIR}
65
66 cd ${TOOLS_SRC_DIR}
67 export JAILHOUSE_VERSION=$(cat ../VERSION)
68 oe_runmake V=1 \
69 CFLAGS="${USER_SPACE_CFLAGS}" \
70 src=${TOOLS_SRC_DIR} obj=${TOOLS_OBJ_DIR} \
71 ${TOOLS_OBJ_DIR}/jailhouse-config-collect ${TOOLS_OBJ_DIR}/jailhouse
72} 51}
73 52
74do_install() { 53do_install:prepend() {
75 oe_runmake \ 54 oe_runmake \
76 PYTHON=python3 \ 55 PYTHON=python3 \
77 V=1 \ 56 V=1 \
@@ -100,10 +79,12 @@ do_install() {
100 install ${B}/inmates/tools/${JH_ARCH}/linux-loader.bin ${D}${INMATES_DIR}/tools/${JH_ARCH} 79 install ${B}/inmates/tools/${JH_ARCH}/linux-loader.bin ${D}${INMATES_DIR}/tools/${JH_ARCH}
101} 80}
102 81
103PACKAGE_BEFORE_PN = "kernel-module-jailhouse pyjailhouse" 82PACKAGE_BEFORE_PN = "pyjailhouse"
104 83
105FILES:${PN} += "${nonarch_base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}" 84FILES:${PN} += "${nonarch_base_libdir}/firmware ${libexecdir} ${sbindir} ${JH_DATADIR}"
106FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}/pyjailhouse" 85# Remove libdir/* appended by setuptools3-base.bbclass for module split to work correctly
86FILES:${PN}:remove = "${libdir}/*"
87FILES:pyjailhouse = "${PYTHON_SITEPACKAGES_DIR}"
107 88
108RDEPENDS:${PN} += " \ 89RDEPENDS:${PN} += " \
109 python3-curses \ 90 python3-curses \