summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ofp/ofp_git.bb
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-04-20 17:46:06 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-05-02 17:54:58 -0300
commit304d35eb872228acc048162705dba944c2483ead (patch)
treea941a7ea5f91f8fd3e243c4d4cfcaa69d46e6122 /recipes-extended/ofp/ofp_git.bb
parent382b4195ce40ef4f6d406d94d7aa3a68396fc8a8 (diff)
downloadmeta-freescale-304d35eb872228acc048162705dba944c2483ead.tar.gz
ofp: add recipes
Signed-off-by: Chunrong Guo <B40290@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/ofp/ofp_git.bb')
-rw-r--r--recipes-extended/ofp/ofp_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-extended/ofp/ofp_git.bb b/recipes-extended/ofp/ofp_git.bb
new file mode 100644
index 00000000..1c6757ef
--- /dev/null
+++ b/recipes-extended/ofp/ofp_git.bb
@@ -0,0 +1,39 @@
1SUMMARY = "An open source user space fast path TCP/IP stack"
2DESCRIPTION = "openfastpath is used to enable accelerated routing/forwarding for IPv4 and IPv6, \
3 tunneling and termination for a variety of protocols."
4HOMEPAGE = "http://www.openfastpath.org"
5SECTION = "console/network"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=fbe4957c430eed6cc20521d4eb429fae"
8
9SRC_URI = "git://github.com/OpenFastPath/ofp.git;protocol=https \
10 file://0001-Patch-to-install-ofp-example-applications.patch \
11 file://Fix-compilation-issue-with-redefinition-of-a-struct.patch \
12"
13SRCREV = "f7ea51b32450ba45d87aff79504e39fad801e7a7"
14
15S = "${WORKDIR}/git"
16
17inherit autotools-brokensep pkgconfig
18
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21DEPENDS = "odp"
22
23EXTRA_OECONF = " \
24 --prefix=/usr \
25 --libdir=${libdir} \
26 --host=${SIMPLE_TARGET_SYS} \
27 --with-odp=${STAGING_DIR_TARGET} \
28"
29
30do_configure () {
31 export SIMPLE_TARGET_SYS="$(echo ${TARGET_SYS} | sed s:${TARGET_VENDOR}::g)"
32
33 ${S}/bootstrap
34 ${S}/configure ${EXTRA_OECONF}
35}
36
37FILES_${PN} += "/usr/ofp/bin"
38FILES_${PN}-dbg += "/usr/ofp/bin/.debug"
39COMPATIBLE_MACHINE = "(ls2088a)"