summaryrefslogtreecommitdiffstats
path: root/recipes-extended/libpkcs11
diff options
context:
space:
mode:
authorC.R. Guo <chunrong.guo@nxp.com>2018-04-03 11:50:20 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-04-11 10:26:14 -0300
commit0edae65e61a4ed1d5555fe565838bf50a4485d27 (patch)
tree22d08f44c912abd81cf8175dfefa14e8d2d2fe0b /recipes-extended/libpkcs11
parent8964e6184f8574326aa0c6187e4d6051b6089913 (diff)
downloadmeta-freescale-0edae65e61a4ed1d5555fe565838bf50a4485d27.tar.gz
libpkcs11: add recipes
*include the following changes: dd1bc90 - APP: Fix for Find Operation not working a06dd4e - Removing Unused Functions 9c3a44c - Changing SecureKey name to Secure Object 8871bdc - Merge pull request #10 in DNDEV/libpkcs11 from ~NXA18717/libpkcs11:master to master 98431e8 - Added PKCS11 Application. 41adb66 - Fixing coverity issuse 66bc41b - Correcting error print message af84c25 - Changing C_Initialize to return correct value 90de92f - Add RSA mechanisms to C_Sign api 7b5d69e - Adding LICENSE to libpkcs11 files b55dcbd - Incorporate change in name for SK Attribute LABEL e713e9a - Removing securekey_api.h and securekey_api_types.h ed96d82 - Removing coverity issues c3f7052 - Add support for OPENSSL verification in do_Sign api fe8cb72 - Add do_Sign api in PKCS application 74aa2ce - Correct CKA_ALLOWED_MECHANISMS attribute addition for object bbfcec7 - Review Rework: Patch 2 - Removing blackduck issues 64e9962 - Add implementation for CK_Sign e62a602 - Changing printf to debug prints 25fa509 - Review Rework: Removing blackduck issues e12226b - Miscellaneous Changes 3917342 - Add implementation for CK_SignInit ced36ca - Review Rework: Adding code for per slot init in C_Initialize 39cfd5e - Adding code for keeping the position in find_list 5319ed0 - Changing names of some functions for blackduck 09fc58f - Adding Securekey function pointer per slot 7ee9cb1 - Adding general.c and general.h for general functions 81f78f7 - Review Rework: Adding session list per token ee38111 - Review rework of comments. 26532be - Correcting the prints in the application. 80d65f4 - Adding more RSA mechanisms 57f325f - Review Rework: Creating 2 objects for each keypair object from securekey ed02339 - Update securekey header files with sign and encrypt api's 2438a8f - Make global function list static & do runtime init c6f51ea - Adding implementation for Object Related APIs 1bf7f57 - Review rework of comments given till now. 06eb609 - Adding framework for getting function pointers from Securekey 0ad6130 - Adding implementation for session functions b0d331b - Adding implementation for general functions 6ca8cb9 - Adding file hierarchy framework c08270f - Initial Commit Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-extended/libpkcs11')
-rw-r--r--recipes-extended/libpkcs11/libpkcs11_git.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-extended/libpkcs11/libpkcs11_git.bb b/recipes-extended/libpkcs11/libpkcs11_git.bb
new file mode 100644
index 00000000..600a1319
--- /dev/null
+++ b/recipes-extended/libpkcs11/libpkcs11_git.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "PKCS library"
2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=803852533e29eb1d6d5e55ad3078b625"
4
5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/libpkcs11;nobranch=1"
6SRCREV = "dd1bc90b0f2171d4dddd9d7d0fc5a2acfb067ab8"
7
8DEPENDS = "openssl secure-obj"
9
10S = "${WORKDIR}/git"
11
12WRAP_TARGET_PREFIX ?= "${TARGET_PREFIX}"
13export CROSS_COMPILE_HOST = "${CROSS_COMPILE}"
14export CROSS_COMPILE_TA = "${CROSS_COMPILE}"
15
16CFLAGS += "-fPIC"
17
18EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS}"'
19
20do_compile() {
21 export OPENSSL_PATH="${RECIPE_SYSROOT}/usr"
22 export CROSS_COMPILE="${WRAP_TARGET_PREFIX}"
23 oe_runmake all
24}
25
26do_install(){
27 mkdir -p ${D}/${libdir}
28 mkdir -p ${D}/${includedir} ${D}/${bindir}
29 cp ${S}/out/export/lib/libpkcs11.so ${D}/${libdir}
30 cp ${S}/out/export/include/*.h ${D}/${includedir}
31 cp ${S}/out/export/app/pkcs11_app ${D}/${bindir}
32}
33
34PARALLEL_MAKE = ""
35INSANE_SKIP_${PN} = "ldflags dev-deps"
36INSANE_SKIP_${PN}-dev = "ldflags dev-elf"
37COMPATIBLE_MACHINE = "(ls1043a|ls1046a|ls2088a|ls1088a)"