summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-11-30 11:07:15 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2016-12-06 16:25:47 -0200
commit282624936335d5ddcf53641d715e1beb42de7659 (patch)
treed10a07eee0c872a1f7116304d0797e837d4ce4f4 /recipes-dpaa
parent80f8122d7ae691ca533238f3f5d8584abab66217 (diff)
downloadmeta-freescale-282624936335d5ddcf53641d715e1beb42de7659.tar.gz
fmlib: Remove native class extend
fmlib doesn't build for native host. Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-dpaa')
-rw-r--r--recipes-dpaa/fmlib/fmlib_git.bb14
1 files changed, 0 insertions, 14 deletions
diff --git a/recipes-dpaa/fmlib/fmlib_git.bb b/recipes-dpaa/fmlib/fmlib_git.bb
index a1945b0d..c2d4575f 100644
--- a/recipes-dpaa/fmlib/fmlib_git.bb
+++ b/recipes-dpaa/fmlib/fmlib_git.bb
@@ -5,8 +5,6 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3f16fa8e677e45af3127c5c4bafc3c00"
5 5
6PR = "r1" 6PR = "r1"
7 7
8DEPENDS_virtclass-native = ""
9
10SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;branch=sdk-v2.0.x" 8SRC_URI = "git://git.freescale.com/ppc/sdk/fmlib.git;branch=sdk-v2.0.x"
11SRCREV = "43fa98fdbf0c697167e415c3f060896d5b482791" 9SRCREV = "43fa98fdbf0c697167e415c3f060896d5b482791"
12 10
@@ -26,25 +24,13 @@ do_compile () {
26 oe_runmake ${FMLIB_TARGET}.a 24 oe_runmake ${FMLIB_TARGET}.a
27} 25}
28 26
29do_compile_virtclass-native () {
30}
31
32do_install () { 27do_install () {
33 oe_runmake install-${FMLIB_TARGET} 28 oe_runmake install-${FMLIB_TARGET}
34} 29}
35 30
36do_install_virtclass-native () {
37 install -d ${D}/${includedir}
38 cp -rf ${S}/include/* ${D}/${includedir}
39}
40
41do_compile[depends] += "virtual/kernel:do_shared_workdir" 31do_compile[depends] += "virtual/kernel:do_shared_workdir"
42 32
43ALLOW_EMPTY_${PN} = "1" 33ALLOW_EMPTY_${PN} = "1"
44 34
45BBCLASSEXTEND = "native"
46COMPATIBLE_HOST_qoriq = ".*"
47COMPATIBLE_HOST ?= "(none)"
48
49PACKAGE_ARCH = "${MACHINE_ARCH}" 35PACKAGE_ARCH = "${MACHINE_ARCH}"
50 36