summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorJun Zhu <junzhu@nxp.com>2022-12-16 15:28:16 +0800
committerJun Zhu <junzhu@nxp.com>2022-12-16 15:51:01 +0800
commitfa2d57d67407f94614f24eea008c4a69ec73bc1c (patch)
tree880b5b1710edc4d7b9d5655a0b25fc6247c72033 /recipes-dpaa2
parentebe0e15e8fe5f606af78ffa89f7b859e1b6e1bb6 (diff)
downloadmeta-freescale-fa2d57d67407f94614f24eea008c4a69ec73bc1c.tar.gz
management-complex: Add recipe for v10.35.0
Signed-off-by: Jun Zhu <junzhu@nxp.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.35.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.35.0.bb b/recipes-dpaa2/management-complex/management-complex_10.35.0.bb
new file mode 100644
index 00000000..d114a92e
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.35.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=1db1363924ceccb1edea921b6495bdc2"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1"
10SRCREV = "836d7bf606b51c18b5e3726d68dcf3b3ac4de74a"
11
12S = "${WORKDIR}/git"
13
14REGLEX:ls2088a = "ls2088a"
15REGLEX:ls2080a = "ls2080a"
16REGLEX:ls1088a = "ls1088a"
17REGLEX:lx2160a = "lx216xa"
18REGLEX:lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES:${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"