summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-15 10:31:03 +0530
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 08:38:13 -0300
commit5f60a6e4ca43ad1e4a1ea7d53ad04e85904247e9 (patch)
treeab311bacb9d8e983b457fc22b86ec07ffe232420 /recipes-dpaa2
parent7ad6fd613ca5c368ff2975d87ce5d128c6929b14 (diff)
downloadmeta-freescale-5f60a6e4ca43ad1e4a1ea7d53ad04e85904247e9.tar.gz
management-complex: add recipe 10.24.0
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.24.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.24.0.bb b/recipes-dpaa2/management-complex/management-complex_10.24.0.bb
new file mode 100644
index 00000000..17049a15
--- /dev/null
+++ b/recipes-dpaa2/management-complex/management-complex_10.24.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "DPAA2 Management Complex Firmware"
2LICENSE = "NXP-Binary-EULA"
3LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=481d6288552113961a835bbabceb0c33"
4
5inherit deploy
6
7INHIBIT_DEFAULT_DEPS = "1"
8
9SRC_URI = "git://github.com/nxp/qoriq-mc-binary;nobranch=1"
10SRCREV = "324817697a4c89a9a940fb7dba1b18909913ee20"
11
12S = "${WORKDIR}/git"
13
14REGLEX_ls2088a = "ls2088a"
15REGLEX_ls2080a = "ls2080a"
16REGLEX_ls1088a = "ls1088a"
17REGLEX_lx2160a = "lx216xa"
18REGLEX_lx2162a = "lx216xa"
19
20do_install () {
21 install -d ${D}/boot
22 install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
23}
24
25do_deploy () {
26 install -d ${DEPLOYDIR}/mc_app
27 install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
28 # make a symlink to the latest binary
29 for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
30 ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
31 done
32}
33addtask deploy before do_build after do_install
34
35PACKAGES += "${PN}-image"
36FILES_${PN}-image += "/boot"
37
38INHIBIT_PACKAGE_STRIP = "1"
39
40COMPATIBLE_MACHINE = "(qoriq-arm64)"
41PACKAGE_ARCH = "${MACHINE_ARCH}"