summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2021-10-14 15:28:55 +0800
committerTing Liu <ting.liu@nxp.com>2021-10-15 21:17:51 +0800
commit565af7f7c405c429b1747c748bc6159f830c4dbb (patch)
treedbd11ce2500677821f715bf4033853b4be3adb32 /recipes-dpaa2
parent3fde9bdf9f04b8243b3cb07363ad32eea4ec1921 (diff)
downloadmeta-freescale-565af7f7c405c429b1747c748bc6159f830c4dbb.tar.gz
restool: update to d29522a
New commits: d29522a dpsw: set mem_size field in ls-addsw to 0 by default d7512d2 dpdmux: set mem_size field in ls-addmux to 0 by default 8fd3a6b restool: increase version to v2.3 53140e4 restool: change version string formatting 34e4e27 add man page for restool 2d46b18 restool: add bash completion script 2b876b5 dpdmai: add support for the new DPDMAI_OPT_CG_PER_PRIORITY create option 6188bc5 restool: support new dpsw_create and dpdmux_create option mem_size 0dd8744 restool: add DPSW_OPT_BP_PER_IF in dpsw create and ls-addsw 1bdfa99 ls-delete: take into account different naming for device links 6dd9314 dpni: memset the statistics feddfa6 dpsw: add support to configure the component-type 282bd30 restool: add support for DPDMUX_OPT_AUTO_MAX_FRAME_LEN 23cdaec restool: print max_frame_length in info command 2876f7c dpni: add page_6 missing structure to dpn_statistics_v10 18c53fc restool: info command shows newly added stats 96ce70e dpdmux: dump interface statistics in info command output afd9831 scripts: add the ls-delete helper script 0977d12 ls-addni: create a DPMCP for each DPIO created disable manpage generation. Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/restool/files/disable-manpage-generation.patch25
-rw-r--r--recipes-dpaa2/restool/restool_git.bb15
2 files changed, 35 insertions, 5 deletions
diff --git a/recipes-dpaa2/restool/files/disable-manpage-generation.patch b/recipes-dpaa2/restool/files/disable-manpage-generation.patch
new file mode 100644
index 00000000..ec512830
--- /dev/null
+++ b/recipes-dpaa2/restool/files/disable-manpage-generation.patch
@@ -0,0 +1,25 @@
1From 5392152e704ff001c41de03445d668227237a87e Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Fri, 15 Oct 2021 09:36:04 +0530
4Subject: [PATCH] disable manpage generation
5
6Signed-off-by: Ting Liu <ting.liu@nxp.com>
7---
8 Makefile | 1 -
9 1 file changed, 1 deletion(-)
10
11diff --git a/Makefile b/Makefile
12index ee669ae..ab6e499 100644
13--- a/Makefile
14+++ b/Makefile
15@@ -60,7 +60,6 @@ install: restool scripts/ls-main scripts/ls-append-dpl scripts/ls-debug scripts/
16 install -D -m 755 scripts/ls-debug $(DESTDIR)$(bindir)/ls-debug
17 $(foreach symlink, $(RESTOOL_SCRIPT_SYMLINKS), sh -c "cd $(DESTDIR)$(bindir) && ln -sf ls-main $(symlink)" ;)
18 install -D -m 755 scripts/restool_completion.sh $(DESTDIR)$(bindir_completion)/restool
19- install -m 0644 -D $(MANPAGE) $(call get_manpage_destination,$(MANPAGE))
20
21 clean:
22 rm -f $(OBJ) $(MANPAGE) \
23--
242.25.1
25
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 7f4a93f7..3ff5afd8 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -2,14 +2,16 @@ SUMMARY = "DPAA2 Resource Manager Tool"
2LICENSE = "BSD" 2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0" 3LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0"
4 4
5RDEPENDS:${PN} += "bash dtc" 5SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \
6 6 file://disable-manpage-generation.patch \
7SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1" 7"
8SRCREV = "8ddbe4c9559ffad5d7e5dd3cd5f00ceeff7f05d4" 8SRCREV = "d29522aef9f92ff2557978d5d3979b771a9576fe"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"' 12inherit bash-completion
13
14EXTRA_OEMAKE = 'CC="${CC}" MANPAGE= EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"'
13 15
14do_install () { 16do_install () {
15 oe_runmake install DESTDIR=${D} 17 oe_runmake install DESTDIR=${D}
@@ -18,3 +20,6 @@ do_install () {
18COMPATIBLE_MACHINE = "(qoriq-arm64)" 20COMPATIBLE_MACHINE = "(qoriq-arm64)"
19PACKAGE_ARCH = "${MACHINE_ARCH}" 21PACKAGE_ARCH = "${MACHINE_ARCH}"
20 22
23RDEPENDS:${PN} += "bash dtc"
24RDEPENDS:${PN}-bash-completion += "bash"
25