summaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2021-10-13 14:15:19 +0530
committerTing Liu <ting.liu@nxp.com>2021-10-15 11:40:51 +0800
commit50c4043470eed14d1a22ec78b327daacfa3d8877 (patch)
treedd36933ca9aa3ea90873cc2771616f37c983baa2 /recipes-dpaa2
parent2cdfab64a588c7570fe87c0fc3d05f061f2b692c (diff)
downloadmeta-freescale-50c4043470eed14d1a22ec78b327daacfa3d8877.tar.gz
restool: ignore maybe-uninitialized warnnings
Fix: In function 'create_dpbp_v9', inlined from 'create_dpbp' at dpbp_commands.c:465:11: dpbp_commands.c:371:17: error: 'dpbp_cfg' may be used uninitialized [-Werror=maybe-uninitialized] 371 | error = dpbp_create(&restool.mc_io, 0, dpbp_cfg, &dpbp_handle); | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ In file included from dpbp_commands.c:43: dpbp_commands.c: In function 'create_dpbp': mc_v9/fsl_dpbp.h:108:5: note: by argument 3 of type 'const struct dpbp_cfg *' to 'dpbp_create' declared here 108 | int dpbp_create(struct fsl_mc_io *mc_io, | ^~~~~~~~~~~ dpbp_commands.c:448:25: note: 'dpbp_cfg' declared here 448 | struct dpbp_cfg dpbp_cfg; | ^~~~~~~~ | In function 'create_dprtc_v9', | inlined from 'create_dprtc' at dprtc_commands.c:463:11: | dprtc_commands.c:369:17: error: 'dprtc_cfg' may be used uninitialized [-Werror=maybe-uninitialized] | 369 | error = dprtc_create(&restool.mc_io, 0, dprtc_cfg, &dprtc_handle); | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | In file included from dprtc_commands.c:42: | dprtc_commands.c: In function 'create_dprtc': | mc_v9/fsl_dprtc.h:126:5: note: by argument 3 of type 'const struct dprtc_cfg *' to 'dprtc_create' declared here | 126 | int dprtc_create(struct fsl_mc_io *mc_io, | | ^~~~~~~~~~~~ | dprtc_commands.c:447:26: note: 'dprtc_cfg' declared here | 447 | struct dprtc_cfg dprtc_cfg; | | ^~~~~~~~~ Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/restool/restool_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 5376d8f7..966f6109 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -9,7 +9,7 @@ SRCREV = "8ddbe4c9559ffad5d7e5dd3cd5f00ceeff7f05d4"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces"' 12EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized"'
13 13
14do_install () { 14do_install () {
15 oe_runmake install DESTDIR=${D} 15 oe_runmake install DESTDIR=${D}