summaryrefslogtreecommitdiffstats
path: root/recipes-downgrade
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2023-10-31 11:40:22 -0700
committerTom Hochstein <tom.hochstein@nxp.com>2023-10-31 12:00:08 -0700
commit7c949461b577bc141bc157c216a66a5b568e279b (patch)
tree12baebadeeac9b4e17b936aa80dfe981a4c39268 /recipes-downgrade
parenta7627341696d2c629066ce3221c9035c945a22a1 (diff)
downloadmeta-freescale-7c949461b577bc141bc157c216a66a5b568e279b.tar.gz
spir: Downgrade to 1.3.239.0.imx
Latest spir is not compatible with downgraded vulkan, so downgrade spir to match. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-downgrade')
-rw-r--r--recipes-downgrade/spir/spirv-headers_1.3.239.0.imx.bb18
-rw-r--r--recipes-downgrade/spir/spirv-tools_1.3.239.0.imx.bb42
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes-downgrade/spir/spirv-headers_1.3.239.0.imx.bb b/recipes-downgrade/spir/spirv-headers_1.3.239.0.imx.bb
new file mode 100644
index 00000000..afd59cbc
--- /dev/null
+++ b/recipes-downgrade/spir/spirv-headers_1.3.239.0.imx.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Machine-readable files for the SPIR-V Registry"
2DESCRIPTION = "Headers are provided in the include directory, with up-to-date \
3headers in the unified1 subdirectory. Older headers are provided according to \
4their version."
5SECTION = "graphics"
6HOMEPAGE = "https://www.khronos.org/registry/spir-v"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=c938b85bceb8fb26c1a807f28a52ae2d"
9
10SRCREV = "d13b52222c39a7e9a401b44646f0ca3a640fbd47"
11SRC_URI = "git://github.com/KhronosGroup/SPIRV-Headers;protocol=https;branch=main"
12PE = "1"
13UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
14S = "${WORKDIR}/git"
15
16inherit cmake
17
18BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-downgrade/spir/spirv-tools_1.3.239.0.imx.bb b/recipes-downgrade/spir/spirv-tools_1.3.239.0.imx.bb
new file mode 100644
index 00000000..5109bb53
--- /dev/null
+++ b/recipes-downgrade/spir/spirv-tools_1.3.239.0.imx.bb
@@ -0,0 +1,42 @@
1SUMMARY = "The SPIR-V Tools project provides an API and commands for \
2processing SPIR-V modules"
3DESCRIPTION = "The project includes an assembler, binary module parser, \
4disassembler, validator, and optimizer for SPIR-V."
5HOMEPAGE = "https://github.com/KhronosGroup/SPIRV-Tools"
6SECTION = "graphics"
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10SRCREV = "63de608daeb7e91fbea6d7477a50debe7cac57ce"
11SRC_URI = "git://github.com/KhronosGroup/SPIRV-Tools.git;branch=main;protocol=https"
12PE = "1"
13UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
14S = "${WORKDIR}/git"
15
16inherit cmake python3native
17
18DEPENDS = "spirv-headers"
19
20EXTRA_OECMAKE += "\
21 -DSPIRV-Headers_SOURCE_DIR=${STAGING_EXECPREFIXDIR} \
22 -DSPIRV_TOOLS_BUILD_STATIC=OFF \
23 -DBUILD_SHARED_LIBS=ON \
24 -DSPIRV_SKIP_TESTS=ON \
25"
26
27do_install:append:class-target() {
28 # Properly set _IMPORT_PREFIX in INTERFACE_LINK_LIBRARIES so that dependent
29 # tools can find the right library
30 sed -i ${D}${libdir}/cmake/SPIRV-Tools/SPIRV-ToolsTarget.cmake \
31 -e 's:INTERFACE_LINK_LIBRARIES.*$:INTERFACE_LINK_LIBRARIES "\$\{_IMPORT_PREFIX\}/lib":'
32}
33
34# all the libraries are unversioned, so don't pack it on PN-dev
35SOLIBS = ".so"
36FILES_SOLIBSDEV = ""
37
38PACKAGES =+ "${PN}-lesspipe"
39FILES:${PN}-lesspipe = "${base_bindir}/spirv-lesspipe.sh"
40RDEPENDS:${PN}-lesspipe += "${PN} bash"
41
42BBCLASSEXTEND = "native nativesdk"