summaryrefslogtreecommitdiffstats
path: root/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb
diff options
context:
space:
mode:
authorVincent Davis Jr <vince@underview.tech>2023-06-12 21:17:03 -0500
committerVincent Davis Jr <vince@underview.tech>2023-06-12 21:17:03 -0500
commitc5ccc3196bbe05c6cece2ccabdbd0976d6d8080d (patch)
treef76f429045d08007e417a8482e7a1af7dee85eb4 /recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb
parentb87d8035571f2e581fb08e9e525d9022fc176106 (diff)
downloadmeta-freescale-c5ccc3196bbe05c6cece2ccabdbd0976d6d8080d.tar.gz
recipes-downgrade/vulkan: rename vulkan packages
Rename from <recipe name>_<version>.bb to <recipe name>_<version>.imx.bb Hopefully making it more obvious that recipes are forks/older version of what's in OE-core. Signed-off-by: Vincent Davis Jr <vince@underview.tech>
Diffstat (limited to 'recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb')
-rw-r--r--recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb b/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb
new file mode 100644
index 00000000..7c7d3e39
--- /dev/null
+++ b/recipes-downgrade/vulkan/vulkan-headers_1.2.182.0.imx.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Vulkan Header files and API registry"
2DESCRIPTION = "Vulkan is a 3D graphics and compute API providing cross-platform access \
3to modern GPUs with low overhead and targeting realtime graphics applications such as \
4games and interactive media. This package contains the development headers \
5for packages wanting to make use of Vulkan."
6HOMEPAGE = "https://www.khronos.org/vulkan/"
7BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Headers"
8SECTION = "libs"
9
10LICENSE = "Apache-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
12SRC_URI = "git://github.com/KhronosGroup/Vulkan-Headers.git;branch=master;protocol=https"
13
14SRCREV = "37164a5726f7e6113810f9557903a117498421cf"
15
16S = "${WORKDIR}/git"
17
18inherit cmake
19
20FILES:${PN} += "${datadir}/vulkan"
21
22UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"