summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2021-10-14 16:49:19 +0800
committerTing Liu <ting.liu@nxp.com>2021-10-15 22:11:36 +0800
commitd70e4ef35a98b6ca589b5fabd541084ca1f4a078 (patch)
treeb4c70abd8ede1734a7f7b22d88b80b329eebc7b7 /recipes-devtools
parent7fade9243aeeef32a972bec3aa263ab7201a7681 (diff)
downloadmeta-freescale-d70e4ef35a98b6ca589b5fabd541084ca1f4a078.tar.gz
qemu-qoriq: upgrade to 4.2
Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/0001-linux-user-remove-host-stime-syscall.patch67
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_4.2.bb (renamed from recipes-devtools/qemu/qemu-qoriq_4.1.0.bb)5
2 files changed, 2 insertions, 70 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq/0001-linux-user-remove-host-stime-syscall.patch b/recipes-devtools/qemu/qemu-qoriq/0001-linux-user-remove-host-stime-syscall.patch
deleted file mode 100644
index 2d3bd7e0..00000000
--- a/recipes-devtools/qemu/qemu-qoriq/0001-linux-user-remove-host-stime-syscall.patch
+++ /dev/null
@@ -1,67 +0,0 @@
1From 0f1f2d4596aee037d3ccbcf10592466daa54107f Mon Sep 17 00:00:00 2001
2From: Laurent Vivier <laurent@vivier.eu>
3Date: Tue, 12 Nov 2019 15:25:56 +0100
4Subject: [PATCH] linux-user: remove host stime() syscall
5
6stime() has been withdrawn from glibc
7(12cbde1dae6f "Use clock_settime to implement stime; withdraw stime.")
8
9Implement the target stime() syscall using host
10clock_settime(CLOCK_REALTIME, ...) as it is done internally in glibc.
11
12Tested qemu-ppc/x86_64 with:
13
14 #include <time.h>
15 #include <stdio.h>
16
17 int main(void)
18 {
19 time_t t;
20 int ret;
21
22 /* date -u -d"2019-11-12T15:11:00" "+%s" */
23 t = 1573571460;
24 ret = stime(&t);
25 printf("ret %d\n", ret);
26 return 0;
27 }
28
29 # date; ./stime; date
30 Tue Nov 12 14:18:32 UTC 2019
31 ret 0
32 Tue Nov 12 15:11:00 UTC 2019
33
34Upstream-Status: Backport
35
36Buglink: https://bugs.launchpad.net/qemu/+bug/1852115
37Reported-by: Cole Robinson <crobinso@redhat.com>
38Signed-off-by: Laurent Vivier <laurent@vivier.eu>
39Reviewed-by: Peter Maydell <peter.maydell@linaro.org>
40Message-Id: <20191112142556.6335-1-laurent@vivier.eu>
41---
42 linux-user/syscall.c | 8 +++++---
43 1 file changed, 5 insertions(+), 3 deletions(-)
44
45diff --git a/linux-user/syscall.c b/linux-user/syscall.c
46index 4e97bcf1e5..ce399a55f0 100644
47--- a/linux-user/syscall.c
48+++ b/linux-user/syscall.c
49@@ -7764,10 +7764,12 @@ static abi_long do_syscall1(void *cpu_env, int num, abi_long arg1,
50 #ifdef TARGET_NR_stime /* not on alpha */
51 case TARGET_NR_stime:
52 {
53- time_t host_time;
54- if (get_user_sal(host_time, arg1))
55+ struct timespec ts;
56+ ts.tv_nsec = 0;
57+ if (get_user_sal(ts.tv_sec, arg1)) {
58 return -TARGET_EFAULT;
59- return get_errno(stime(&host_time));
60+ }
61+ return get_errno(clock_settime(CLOCK_REALTIME, &ts));
62 }
63 #endif
64 #ifdef TARGET_NR_alarm /* not on alpha */
65--
662.24.0
67
diff --git a/recipes-devtools/qemu/qemu-qoriq_4.1.0.bb b/recipes-devtools/qemu/qemu-qoriq_4.2.bb
index 26c78639..f788f724 100644
--- a/recipes-devtools/qemu/qemu-qoriq_4.1.0.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_4.2.bb
@@ -13,10 +13,9 @@ SRC_URI = "gitsm://source.codeaurora.org/external/qoriq/qoriq-components/qemu;no
13 file://powerpc_rom.bin \ 13 file://powerpc_rom.bin \
14 file://run-ptest \ 14 file://run-ptest \
15 file://0002-Add-subpackage-ptest-which-runs-all-unit-test-cases-.patch \ 15 file://0002-Add-subpackage-ptest-which-runs-all-unit-test-cases-.patch \
16 file://0001-linux-user-remove-host-stime-syscall.patch \
17 " 16 "
18 17
19SRCREV = "0b88a503e43ca629d6e8165638ac6b312e5c66bd" 18SRCREV = "14fda5a42df6c72e890d6a97ff88c5852172604b"
20 19
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
22 21
@@ -53,7 +52,7 @@ do_install_ptest() {
53} 52}
54 53
55PACKAGECONFIG ??= " \ 54PACKAGECONFIG ??= " \
56 fdt sdl kvm aio libusb vhost \ 55 fdt sdl kvm aio libusb vhost numa \
57 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \ 56 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \
58" 57"
59PACKAGECONFIG:class-nativesdk ??= "fdt sdl kvm" 58PACKAGECONFIG:class-nativesdk ??= "fdt sdl kvm"