summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorVincent Prince <vincent.prince.fr@gmail.com>2018-05-22 13:45:08 +0200
committerVincent Prince <vincent.prince.fr@gmail.com>2018-05-22 14:43:52 +0200
commita4ea62756cdfaefe27521cdcd748092bb2d18cbb (patch)
treedc4ecce92e81a47e663c861a66bbf8fb8bd42ab4 /recipes-devtools
parent827bda6303c9d637efb4b94727b67e1857760171 (diff)
downloadmeta-freescale-a4ea62756cdfaefe27521cdcd748092bb2d18cbb.tar.gz
utp-com: Add recipe
This utility is used to send commands to the device using the NXP's UTP protocol. Signed-off-by: Vincent Prince <vincent.prince.fr@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch19
-rw-r--r--recipes-devtools/utp-com/utp-com_git.bb28
2 files changed, 47 insertions, 0 deletions
diff --git a/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch b/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch
new file mode 100644
index 00000000..5db050c1
--- /dev/null
+++ b/recipes-devtools/utp-com/utp-com/0001-Fix-Makefile-for-crosscompilation.patch
@@ -0,0 +1,19 @@
1--- a/makefile
2+++ b/makefile
3@@ -1,10 +1,12 @@
4-CC=gcc
5-CFLAGS=-I. -Wall -O2
6-DEPS=
7+CC ?= gcc
8+CFLAGS ?= -I. -Wall -O2
9+LDFLAGS ?=
10+DEPS ?=
11+
12 OBJ=utp_com.o
13
14 %.o: %.c $(DEPS)
15 $(CC) -c -o $@ $< $(CFLAGS)
16
17 utp_com: $(OBJ)
18- gcc -o $@ $^ $(CFLAGS)
19+ $(CC) -o $@ $^ $(LDFLAGS)
diff --git a/recipes-devtools/utp-com/utp-com_git.bb b/recipes-devtools/utp-com/utp-com_git.bb
new file mode 100644
index 00000000..163f5852
--- /dev/null
+++ b/recipes-devtools/utp-com/utp-com_git.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "Tool used to send commands to hardware via NXP's UTP protocol"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022"
4
5DEPENDS = "sg3-utils"
6
7SRCREV = "7fe590fef812561cceb08aaa10b64e9bac8f542f"
8SRC_URI = " \
9 git://github.com/ixonos/utp_com;protocol=https \
10 file://0001-Fix-Makefile-for-crosscompilation.patch \
11"
12
13PV = "1.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile () {
20 oe_runmake
21}
22
23do_install () {
24 install -d -m 0755 ${D}${bindir}
25 install -m 0755 ${S}/utp_com ${D}${bindir}/utp_com
26}
27
28BBCLASSEXTEND = "native nativesdk"