summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2021-10-15 16:13:53 +0800
committerTing Liu <ting.liu@nxp.com>2021-10-15 22:11:36 +0800
commit93d26c3d784f38b5629f31eb08ae7169c44ccb31 (patch)
tree9eea3870c4a5af37b4b7613517008d050bda0738 /recipes-devtools
parent33e2435e2f3421b1ad205e8c5212c66d836c6080 (diff)
downloadmeta-freescale-93d26c3d784f38b5629f31eb08ae7169c44ccb31.tar.gz
cst: suppress deprecated-declarations error
Fix below build error with openssl 3.0: | gcc -c -g -Wall -Wno-strict-aliasing -Werror -Itools/header_generation/create_hdr_isbc/include/ -Itools/header_generation/create_hdr_esbc/include/ -Itools/header_generation/create_hdr_pbi/include/ -Itools/header_generation/create_hdr_cf/include/ -Itools/fuse_provisioning/include/ -Itaal/include -Icommon/include -Ilib_hash_drbg/include -isystem.../usr/include -O2 -pipe common/crypto_utils.c | common/crypto_utils.c: In function 'crypto_hash_init' | common/crypto_utils.c:46:2: error: 'SHA256_Init' is deprecated: Since OpenSSL 3.0 [-Werror=deprecated-declarations] | 46 | SHA256_Init(c); | | ^~~~~~~~~~~ | In file included from .../usr/include/openssl/x509.h:41, | from .../usr/include/openssl/ssl.h:31, | from common/crypto_utils.c:37: | .../usr/include/openssl/sha.h:73:27: note: declared here | 73 | OSSL_DEPRECATEDIN_3_0 int SHA256_Init(SHA256_CTX *c); | | ^~~~~~~~~~~ | cc1: all warnings being treated as errors | make: *** [Makefile:172: crypto_utils.o] Error 1 | ERROR: oe_runmake failed | WARNING: exit code 1 from a shell command. | NOTE: recipe cst-native-git-r0: task do_compile: Failed Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/cst/cst_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/cst/cst_git.bb
index 71df0a35..d4a9a859 100644
--- a/recipes-devtools/cst/cst_git.bb
+++ b/recipes-devtools/cst/cst_git.bb
@@ -24,6 +24,7 @@ SRCREV = "dfe30d3f05cfe281896482839e57ed49c52f2088"
24S = "${WORKDIR}/git" 24S = "${WORKDIR}/git"
25 25
26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"' 26EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}"'
27CFLAGS:append = ' -Wno-deprecated-declarations'
27 28
28PARALLEL_MAKE = "" 29PARALLEL_MAKE = ""
29 30