summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-12-15 09:55:55 +0530
committerOtavio Salvador <otavio@ossystems.com.br>2020-12-16 08:38:13 -0300
commit8da53a53f4642467e758491be9dba3110887e04b (patch)
tree2c92b4c332d85f169a5db6deb7c76d297e0c611e /recipes-devtools
parent05c19a765a891137737c53b1bd7431539e6238c5 (diff)
downloadmeta-freescale-8da53a53f4642467e758491be9dba3110887e04b.tar.gz
qemu-qoriq: overide do_install_ptest
qemu-qoriq reuses poky's qemu.inc which has upgraded to 5.1. qemu-qoriq is based on 4.1 in which tests/data/acpi/disassemle-aml.sh does not exist. This leads to do_install_ptest fail. Override do_install_ptest in qemu-qoriq recipe. Signed-off-by: Ting Liu <ting.liu@nxp.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_4.1.0.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_4.1.0.bb b/recipes-devtools/qemu/qemu-qoriq_4.1.0.bb
index 0c822735..0f91658e 100644
--- a/recipes-devtools/qemu/qemu-qoriq_4.1.0.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_4.1.0.bb
@@ -40,6 +40,18 @@ do_install_append_class-nativesdk() {
40 ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)} 40 ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)}
41} 41}
42 42
43do_install_ptest() {
44 cp -rL ${B}/tests ${D}${PTEST_PATH}
45 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
46
47 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
48 # Don't check the file genreated by configure
49 sed -i -e '/wildcard config-host.mak/d' \
50 -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
51 sed -i -e 's,${HOSTTOOLS_DIR}/python3,${bindir}/python3,' \
52 ${D}/${PTEST_PATH}/tests/qemu-iotests/common.env
53}
54
43PACKAGECONFIG ??= " \ 55PACKAGECONFIG ??= " \
44 fdt sdl kvm aio libusb \ 56 fdt sdl kvm aio libusb \
45 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \ 57 ${@bb.utils.filter('DISTRO_FEATURES', 'alsa xen', d)} \