summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@nxp.com>2016-09-13 10:56:18 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-09-13 17:45:41 -0300
commit8c208e11b47e74ba94c3cbbb58db8801eeb6e5c9 (patch)
tree5ab1baf27dfad1a7ca6219beac259a90f533f43a /recipes-devtools
parent5aed0685950f582f8759c93e73cb8caa077a154e (diff)
downloadmeta-freescale-8c208e11b47e74ba94c3cbbb58db8801eeb6e5c9.tar.gz
qemu-qoriq: fix do_install_ptest_base issue
Fix the following build error: | DEBUG: Executing shell function do_install_ptest_base | cp: cannot stat '.../qemu-qoriq/git-r1/git/tests/Makefile.include': No such file or directory | WARNING: exit code 1 from a shell command. Signed-off-by: Zhenhua Luo <zhenhua.luo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index d7651fbc..5ae7d025 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -72,6 +72,13 @@ do_install_append() {
72 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi 72 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
73} 73}
74 74
75do_install_ptest() {
76 cp -rL ${B}/tests ${D}${PTEST_PATH}
77 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
78
79 cp ${S}/tests/Makefile ${D}${PTEST_PATH}/tests
80}
81
75FILES_${PN} += "${datadir}/qemu/" 82FILES_${PN} += "${datadir}/qemu/"
76INSANE_SKIP_${PN} += "dev-deps" 83INSANE_SKIP_${PN} += "dev-deps"
77 84