summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-01-20 10:38:24 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-01-20 11:10:15 -0300
commit84757e4a9b497960d8c9eacc555495d805c5acae (patch)
tree340c4255ee78fdf5baf7a47dec66d4a64ba912ed /recipes-devtools
parent728ce4f1677012db95c6f946f43e272762d98175 (diff)
downloadmeta-freescale-84757e4a9b497960d8c9eacc555495d805c5acae.tar.gz
devregs: update to latest version and add imx8mn support
Update the package to the latest version available upstream, and add patch which introduces support for i.MX8M Nano SoC. Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/devregs/devregs_git.bb6
-rw-r--r--recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch33
2 files changed, 37 insertions, 2 deletions
diff --git a/recipes-devtools/devregs/devregs_git.bb b/recipes-devtools/devregs/devregs_git.bb
index 3bac55a4..61bb0059 100644
--- a/recipes-devtools/devregs/devregs_git.bb
+++ b/recipes-devtools/devregs/devregs_git.bb
@@ -3,8 +3,10 @@ SECTION = "devel"
3LICENSE = "GPL-1" 3LICENSE = "GPL-1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924" 4LIC_FILES_CHKSUM = "file://COPYING;md5=5003fa041d799dd5dd5f646b74e36924"
5 5
6SRCREV = "34ed402b92920864b89e0fd1e76bae3aa340baaa" 6SRCREV = "6d2ad752ce92ad37ab144d9c3322f3dcd43398e5"
7SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=http" 7SRC_URI = "git://github.com/boundarydevices/devregs.git;protocol=http \
8 file://0001-devregs-add-support-for-imx8mn-soc.patch \
9"
8 10
9PV = "1.0+${SRCPV}" 11PV = "1.0+${SRCPV}"
10 12
diff --git a/recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch b/recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch
new file mode 100644
index 00000000..b838ad03
--- /dev/null
+++ b/recipes-devtools/devregs/files/0001-devregs-add-support-for-imx8mn-soc.patch
@@ -0,0 +1,33 @@
1From cca909511ead5023f4a9f71412d79411a384326d Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
3Date: Mon, 13 Jan 2020 17:32:19 +0000
4Subject: [PATCH] devregs: add support for imx8mn soc
5
6i.MX8M Nano SoC is very close to i.MX8M Mini, therefore we would allow
7them to use the same register description file.
8
9Upstream-Status: Submitted [https://github.com/boundarydevices/devregs/pull/5]
10
11Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
12---
13 src/devregs.cpp | 4 ++++
14 1 file changed, 4 insertions(+)
15
16diff --git a/src/devregs.cpp b/src/devregs.cpp
17index 67c52eb..d540894 100644
18--- a/src/devregs.cpp
19+++ b/src/devregs.cpp
20@@ -717,6 +717,10 @@ static int getcpu(unsigned &cpu, const char *path) {
21 cpu = 0x82;
22 break;
23 }
24+ if (strstr(inBuf, "i.MX8MN")) {
25+ cpu = 0x82;
26+ break;
27+ }
28 if (!get_rev(inBuf, "Revision", &cpu))
29 if (cpu != 0x10)
30 break;
31--
322.17.1
33