summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2015-07-23 16:02:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2015-07-28 23:26:59 -0300
commit6a868a671472d454b407a165fc31c5f7dfe783c6 (patch)
tree7bd2ab13a04d14215264cc992501970cacfb20ef /recipes-devtools
parent62e212fe4812a6c726df4ac8e77d4a77e0e54247 (diff)
downloadmeta-freescale-6a868a671472d454b407a165fc31c5f7dfe783c6.tar.gz
Move meta-fsl-ppc content to layer root
This commit is just a rename of all contents of meta-fsl-ppc subdirectory to this layer's root, merging the contents of common files, subsequent changes are based on top of that. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu_fslgit.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu_fslgit.bb b/recipes-devtools/qemu/qemu_fslgit.bb
new file mode 100644
index 00000000..f977a379
--- /dev/null
+++ b/recipes-devtools/qemu/qemu_fslgit.bb
@@ -0,0 +1,55 @@
1require recipes-devtools/qemu/qemu.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
4 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
5
6# This means QEMU v2.2.0 with FSL specific patches applied
7PV = "2.2.0+fsl"
8
9# NOTE: this recipe requires poky's qemu.inc which assumes version 2.3
10# where glx enable config option changed to --enable-opengl. For now we
11# restore it, but we should remove the following lines when upgrading
12# to qemu 2.3:
13PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa"
14
15SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=master"
16SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a"
17
18S = "${WORKDIR}/git"
19
20QEMU_TARGETS = "ppc"
21PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl --enable-libusb'
22EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
23EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
24EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
25EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
26EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
27EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
28
29do_configure_prepend() {
30 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config
31}
32
33do_configure_append () {
34 grep 'CONFIG_FDT=y' config-host.mak
35}
36
37# gets around qemu.inc trying to install powerpc_rom.bin
38do_install_prepend() {
39 touch ${WORKDIR}/powerpc_rom.bin
40}
41
42do_install_append() {
43 rm ${WORKDIR}/powerpc_rom.bin
44 # Prevent QA warnings about installed ${localstatedir}/run
45 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
46}
47
48INSANE_SKIP_${PN} += "dev-deps"
49
50# This is only meant to be build to run on the target
51# for the given arch types listed, otherwise don't let
52# the package get built. COMPATIBLE_HOST would not work
53# because it was too generic
54COMPATIBLE_MACHINE = "a^"
55COMPATIBLE_MACHINE_libc-glibc_qoriq-ppc = ".*"