summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-16 08:24:40 -0700
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-19 15:45:42 -0300
commit68fea14376ff5347edf8330db593ca24c46b1c4f (patch)
treecb65afdc48f0b82225f0cecc871ae60ea98dd586 /recipes-devtools
parent954d7a7d7afc3ad4950eb0fd354a6f4bd06d911a (diff)
downloadmeta-freescale-68fea14376ff5347edf8330db593ca24c46b1c4f.tar.gz
cst: Fix build with gcc10
Fixes create_hdr_common.c:42: multiple definition of `file_field'; parse_utils.o:/mnt/b/yoe/master/build/tmp/work/x86_64-linux/cst-native/git-r0/git/common/parse_utils.c:29: first defined here | collect2: error: ld returned 1 exit status | make: *** [Makefile:131: create_hdr_isbc] Error 1 Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch43
-rw-r--r--recipes-devtools/cst/cst_git.bb1
2 files changed, 44 insertions, 0 deletions
diff --git a/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch b/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
new file mode 100644
index 00000000..d25675aa
--- /dev/null
+++ b/recipes-devtools/cst/cst/0001-tools-Mark-struct-input_field-file_field-extern.patch
@@ -0,0 +1,43 @@
1From 81ec65e72f357fb2c395e40c5195434bbaddf7f7 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 16 May 2020 08:21:52 -0700
4Subject: [PATCH] tools: Mark struct input_field file_field extern
5
6This struct is already defined in common/parse_utils.c
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 tools/header_generation/create_hdr_common.c | 2 +-
12 tools/pbi_creation/create_pbi_common.c | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/tools/header_generation/create_hdr_common.c b/tools/header_generation/create_hdr_common.c
16index bfa90a3..edf632c 100644
17--- a/tools/header_generation/create_hdr_common.c
18+++ b/tools/header_generation/create_hdr_common.c
19@@ -39,7 +39,7 @@
20 #include <crypto_utils.h>
21
22 extern struct g_data_t gd;
23-struct input_field file_field;
24+extern struct input_field file_field;
25
26 extern char line_data[];
27 static struct option long_options[] = {
28diff --git a/tools/pbi_creation/create_pbi_common.c b/tools/pbi_creation/create_pbi_common.c
29index ff2ed84..bd976da 100644
30--- a/tools/pbi_creation/create_pbi_common.c
31+++ b/tools/pbi_creation/create_pbi_common.c
32@@ -57,7 +57,7 @@ static char *parse_list[] = {
33
34 extern struct g_data_t gd;
35 extern char line_data[];
36-struct input_field file_field;
37+extern struct input_field file_field;
38
39 #define NUM_PARSE_LIST (sizeof(parse_list) / sizeof(char *))
40
41--
422.26.2
43
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/cst/cst_git.bb
index c55a90be..fef0fbcf 100644
--- a/recipes-devtools/cst/cst_git.bb
+++ b/recipes-devtools/cst/cst_git.bb
@@ -17,6 +17,7 @@ inherit kernel-arch
17#SECURE_PUB_KEY = "/path/srk.pub" 17#SECURE_PUB_KEY = "/path/srk.pub"
18 18
19SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \ 19SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cst;nobranch=1 \
20 file://0001-tools-Mark-struct-input_field-file_field-extern.patch \
20" 21"
21SRCREV = "9aafbdf2441858ceca2779279b6876c6bdc2d3ed" 22SRCREV = "9aafbdf2441858ceca2779279b6876c6bdc2d3ed"
22 23