summaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-06-14 14:01:51 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-06-18 14:25:33 -0300
commit220bfee06c73105fb8417fbfe6a28ce0dc9359ea (patch)
tree13b3a3368462e18d46f978f6b093d4db0363afcc /recipes-devtools
parenta2a401634c7434e4ae796cfeb6cadeb8ee38d089 (diff)
downloadmeta-freescale-220bfee06c73105fb8417fbfe6a28ce0dc9359ea.tar.gz
qemu-qoriq: add recipes
*include the following changes: 6c297a7 - vfio fsl-mc: Expose DPIO cacheable region as cacheable 8e929a8 - fsl-mc: mc-bus device fdt node creation 4be2ad9 - fsl-mc: Add APIs to provide root mc-portal region b1abcf2 - fsl-mc: Add API to provide mc-portals region 22d303a - vfio fsl-mc: Configure and setup irqfd cfc1b9a - vfio fsl-mc: Enable DPMCP emulation c5b28d1 - vfio fsl-mc: Add support to close dpmcp command interface 56353d9 - vfio fsl-mc: Support non dprc/dpmcp command interface on dpmcp 12a9dae - vfio fsl-mc: Add support for dprc command interface on dpmcp a24861b - vfio fsl-mc: Add support to open dpmcp command interface ae9efbb - vfio fsl-mc: forward non-emulated mc commands to VFIO 913ab98 - vfio fsl-mc: Add support of get_obj_irq mc commands 9883a03 - vfio fsl-mc: Add support of set obj_irq mc commands 57db3b4 - vfio fsl-mc: Add support of get_irq mc commands c87c8c1 - vfio fsl-mc: Add support of set_irq mc commands 35413a8 - vfio fsl-mc: Add support of get_obj_region command edca25c - vfio-fsl-mc: Add support of dprc get-attr command 74ca7d2 - vfio-fsl-mc: Add support of dprc open/close command bb895ff - vfio-fsl-mc: Add framework for handling mc-portal commands eb51475 - vfio fsl-mc: Scan dprc container and realize child devices 82a1b97 - vfio-fsl-mc: Register mc-device regions with mc-bus f2a56a1 - vfio fsl-mc: add support for non-dprc device c36e7f6 - vfio fsl-mc: Add nested dprc support be171ec - vfio fsl-mc: framework to support fsl-mc-bus in vfio 16010da - vfio fsl-mc: Sync linux header for fsl-mc device be260fc - fsl-mc: add interfaces to set/get msi messages f9756ce - fsl-mc: Add mc-bus-devices region registration interface 5ae0227 - vfio-fsl-mc: Initialize fsl-mc bus devices device-id 9bdfa45 - fsl-mc: Add mc-bus-devices registration interface c996be1 - fsl-mc: define device-id map for mc-bus devices Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/memfd.patch41
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/powerpc_rom.binbin0 -> 4096 bytes
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/run-ptest10
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb72
4 files changed, 123 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq/memfd.patch b/recipes-devtools/qemu/qemu-qoriq/memfd.patch
new file mode 100644
index 00000000..d9e7a455
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/memfd.patch
@@ -0,0 +1,41 @@
1From d60ecdd94f4054aa0ec615824d5efdb4cebc7db9 Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Thu, 19 Apr 2018 11:47:16 +0800
4Subject: [PATCH] memfd
5
6---
7 configure | 2 +-
8 util/memfd.c | 4 +---
9 2 files changed, 2 insertions(+), 4 deletions(-)
10
11diff --git a/configure b/configure
12index be4d326..cb5197c 100755
13--- a/configure
14+++ b/configure
15@@ -3735,7 +3735,7 @@ fi
16 # check if memfd is supported
17 memfd=no
18 cat > $TMPC << EOF
19-#include <sys/memfd.h>
20+#include <sys/mman.h>
21
22 int main(void)
23 {
24diff --git a/util/memfd.c b/util/memfd.c
25index 4571d1a..412e94a 100644
26--- a/util/memfd.c
27+++ b/util/memfd.c
28@@ -31,9 +31,7 @@
29
30 #include "qemu/memfd.h"
31
32-#ifdef CONFIG_MEMFD
33-#include <sys/memfd.h>
34-#elif defined CONFIG_LINUX
35+#if defined CONFIG_LINUX && !defined CONFIG_MEMFD
36 #include <sys/syscall.h>
37 #include <asm/unistd.h>
38
39--
402.7.4
41
diff --git a/recipes-devtools/qemu/qemu-qoriq/powerpc_rom.bin b/recipes-devtools/qemu/qemu-qoriq/powerpc_rom.bin
new file mode 100644
index 00000000..c4044296
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/powerpc_rom.bin
Binary files differ
diff --git a/recipes-devtools/qemu/qemu-qoriq/run-ptest b/recipes-devtools/qemu/qemu-qoriq/run-ptest
new file mode 100644
index 00000000..2206b319
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/run-ptest
@@ -0,0 +1,10 @@
1#!/bin/sh
2#
3#This script is used to run qemu test suites
4#
5
6ptestdir=$(dirname "$(readlink -f "$0")")
7export SRC_PATH=$ptestdir
8
9cd $ptestdir/tests
10make -f Makefile.include -k runtest-TESTS | sed '/: OK/ s/^/PASS: /g'
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
new file mode 100644
index 00000000..7423b542
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -0,0 +1,72 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3require recipes-devtools/qemu/qemu.inc
4
5inherit ptest
6
7RDEPENDS_${PN}-ptest = "bash make"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
10 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
11
12SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/qemu;nobranch=1 \
13 file://powerpc_rom.bin \
14 file://run-ptest \
15 file://memfd.patch \
16 "
17
18SRCREV = "6c297a7ddd355d499ddd31353a763d57a092f851"
19
20S = "${WORKDIR}/git"
21
22COMPATIBLE_HOST_mipsarchn32 = "null"
23COMPATIBLE_HOST_mipsarchn64 = "null"
24
25PROVIDES = "qemu"
26
27python() {
28 pkgs = d.getVar('PACKAGES', True).split()
29 for p in pkgs:
30 if 'qemu-qoriq' in p:
31 d.appendVar("RPROVIDES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
32 d.appendVar("RCONFLICTS_%s" % p, p.replace('qemu-qoriq', 'qemu'))
33 d.appendVar("RREPLACES_%s" % p, p.replace('qemu-qoriq', 'qemu'))
34}
35
36PPC_OECONF = '--enable-fdt --enable-kvm --with-system-pixman --disable-werror'
37EXTRA_OECONF_qoriq-arm64 = "--prefix=${prefix} --target-list=aarch64-softmmu --enable-fdt --enable-kvm --with-system-pixman --disable-werror"
38EXTRA_OECONF_qoriq-arm = "--prefix=${prefix} --target-list=arm-softmmu --enable-fdt --enable-kvm --with-system-pixman --disable-werror"
39EXTRA_OECONF_e5500-64b = "--prefix=${prefix} --target-list=ppc64-softmmu ${PPC_OECONF}"
40EXTRA_OECONF_e6500-64b = "--prefix=${prefix} --target-list=ppc64-softmmu ${PPC_OECONF}"
41EXTRA_OECONF_e6500 = "--prefix=${prefix} --target-list=ppc64-softmmu ${PPC_OECONF}"
42EXTRA_OECONF_e5500 = "--prefix=${prefix} --target-list=ppc64-softmmu ${PPC_OECONF}"
43EXTRA_OECONF_e500v2 = "--prefix=${prefix} --target-list=ppc-softmmu ${PPC_OECONF}"
44EXTRA_OECONF_e500mc = "--prefix=${prefix} --target-list=ppc-softmmu ${PPC_OECONF}"
45
46DISABLE_STATIC = ""
47
48do_install_append() {
49 # Prevent QA warnings about installed ${localstatedir}/run
50 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
51 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
52}
53
54do_compile_ptest() {
55 make buildtest-TESTS
56}
57
58do_install_ptest() {
59 cp -rL ${B}/tests ${D}${PTEST_PATH}
60 find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {}
61
62 cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests
63 # Don't check the file genreated by configure
64 sed -i -e '/wildcard config-host.mak/d' \
65 -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include
66}
67
68INSANE_SKIP_${PN} += "already-stripped"
69FILES_${PN} += "/usr/share/qemu/* /usr/var/*"
70
71# FIXME: Avoid WARNING due missing patch for native/nativesdk
72BBCLASSEXTEND = ""