summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/qemu/qemu-qoriq_git.bb
diff options
context:
space:
mode:
authorZhenhua Luo <zhenhua.luo@freescale.com>2015-08-17 18:12:52 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-04-19 15:03:15 -0300
commitd869d9080dfd9a44fd84b3a57acee08666ab45b8 (patch)
treed67416d63b2f5dd6635538a2a983cab780f3b200 /recipes-devtools/qemu/qemu-qoriq_git.bb
parent16a50412b0adcbd51fce55006fe15155181be06b (diff)
downloadmeta-freescale-d869d9080dfd9a44fd84b3a57acee08666ab45b8.tar.gz
qemu: unify the recipe for QorIQ ARM and QorIQ PPC
* rename recipe to qemu-qoriq_git.bb to be product specific * add DESCRIPTION * conditionally define QEMU_TARGETS and EXTRA_OECONF * skip dev-deps check to fix build error * add COMPATIBLE_MACHINE Signed-off-by: Zhenhua Luo <zhenhua.luo@freescale.com>
Diffstat (limited to 'recipes-devtools/qemu/qemu-qoriq_git.bb')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
new file mode 100644
index 00000000..3c613170
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -0,0 +1,65 @@
1require recipes-devtools/qemu/qemu.inc
2
3DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \
4fixes of QorIQ ARM and QorIQ PPC targets, the recipe assumes that glx enable \
5config option is changed to --enable-opengl. The recipe only works for FSL \
6QorIQ machines. The poky version should be used for native/nativesdk build."
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
9 file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
10
11# This means QEMU v2.2.0 with FSL specific patches applied
12PV = "2.2.0+${SRCPV}"
13
14# FIXME: this recipe requires poky's qemu.inc which assumes version 2.3
15# where glx enable config option changed to --enable-opengl. For now we
16# restore it, but we should remove the following lines when upgrading
17# to qemu 2.3:
18PACKAGECONFIG[glx] = "--enable-glx,--disable-glx,mesa"
19
20SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=master"
21SRCREV = "00ac004143e9fe46944a1885b04268fcd3a95a3a"
22
23S = "${WORKDIR}/git"
24
25QEMU_TARGETS_qoriq-ppc = "ppc"
26QEMU_TARGETS_qoriq-arm = "arm"
27PPC_OECONF = '${SDL} --cross-prefix=${TARGET_PREFIX} --disable-werror --disable-vnc --disable-bluez --disable-curl --enable-libusb'
28EXTRA_OECONF_e5500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
29EXTRA_OECONF_e6500-64b = "--target-list=ppc64-softmmu ${PPC_OECONF}"
30EXTRA_OECONF_e6500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
31EXTRA_OECONF_e5500 = "--target-list=ppc64-softmmu ${PPC_OECONF}"
32EXTRA_OECONF_e500v2 = "--target-list=ppc-softmmu ${PPC_OECONF}"
33EXTRA_OECONF_e500mc = "--target-list=ppc-softmmu ${PPC_OECONF}"
34
35inherit pkgconfig
36
37# Append build host pkg-config paths for native target since the host may provide sdl
38do_configure_prepend() {
39 export PKG_CONFIG=${STAGING_DIR_NATIVE}${bindir_native}/pkg-config
40}
41
42do_configure_append () {
43 if ! grep 'CONFIG_FDT=y' config-host.mak; then
44 echo "CONFIG_RDMA=y" >> config-host.mak
45 fi
46}
47
48# gets around qemu.inc trying to install powerpc_rom.bin
49do_install_prepend() {
50 touch ${WORKDIR}/powerpc_rom.bin
51}
52
53do_install_append() {
54 rm ${WORKDIR}/powerpc_rom.bin
55 # Prevent QA warnings about installed ${localstatedir}/run
56 if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi
57}
58
59FILES_${PN} += "/usr/share/qemu/"
60INSANE_SKIP_${PN} += "dev-deps"
61
62# FIXME: Avoid WARNING due missing patch for native/nativesdk
63BBCLASSEXTEND = ""
64
65COMPATIBLE_MACHINE = "(qoriq)"