summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/cst
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-10-18 13:06:12 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-10-18 11:42:30 -0200
commit22c8da98de535a01ce74b8300c373aea0c0371de (patch)
tree6aa297bfa27754f13f292c2aed10efa30655c54b /recipes-devtools/cst
parent0f9386eb80bfd132c7e69c94d0d720a0041343cd (diff)
downloadmeta-freescale-22c8da98de535a01ce74b8300c373aea0c0371de.tar.gz
cst :update to 1afb40c
*This includes the following changes: 1afb40c - Make SRK table default option 1650003 - Make ls1088_ls2088.sh executable 4ae056a - Generate SRK hash value c3e7c34 - LS1088 QSPI: Change in address in input file fe4e0da - LS104x_1012: Add signing of bootscript_decap in case of NAND 8f42212 - LS1088 SD: Add input files for LS1088ardb SD 88b3f45 - Merge pull request #73 in SDK/cst from ~B57223/cst-create-pbi:master to master 63bfb68 - To enable blob, added input file d124628 - LS1021ATWR: Change SPL hdr load address 12c489f - LS2088_1088: Add uni_sign input files for sd boot 04ac1a0 - LS2088_1088: Sample uni_pbi input file for sd boot 23bf3b7 - LS2088_1088: Modify tool to add pbi commands for sd secure 46f4045 - Enable cmd line flag "--u" urand option for gen_otpmk_drbg *Fix fails compilation due to uninitialized variables Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-devtools/cst')
-rw-r--r--recipes-devtools/cst/cst/0001-gen_otpmk_drbg-fails-compilation-due-to-uninitialize.patch28
-rw-r--r--recipes-devtools/cst/cst_git.bb6
2 files changed, 32 insertions, 2 deletions
diff --git a/recipes-devtools/cst/cst/0001-gen_otpmk_drbg-fails-compilation-due-to-uninitialize.patch b/recipes-devtools/cst/cst/0001-gen_otpmk_drbg-fails-compilation-due-to-uninitialize.patch
new file mode 100644
index 00000000..0dc5c3a6
--- /dev/null
+++ b/recipes-devtools/cst/cst/0001-gen_otpmk_drbg-fails-compilation-due-to-uninitialize.patch
@@ -0,0 +1,28 @@
1From 6eb82ed1ba56c398e89f04fb848c5f3c4543e772 Mon Sep 17 00:00:00 2001
2From: Chunrong Guo <chunrong.guo@nxp.com>
3Date: Wed, 20 Sep 2017 13:22:34 +0800
4Subject: [PATCH] gen_otpmk_drbg: fails compilation due to uninitialized
5 variables
6
7Upstream-Status: Submitted
8Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
9---
10 tools/key_generation/gen_otpmk_drbg.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/tools/key_generation/gen_otpmk_drbg.c b/tools/key_generation/gen_otpmk_drbg.c
14index 6465367..33e5ea6 100644
15--- a/tools/key_generation/gen_otpmk_drbg.c
16+++ b/tools/key_generation/gen_otpmk_drbg.c
17@@ -142,7 +142,7 @@ int main(int argc, char *argv[])
18 {
19 char otpmk_in[2];
20 int c, i, l, ret;
21- char *string;
22+ char *string = NULL;
23 char urand_flag = 0;
24
25 printf("\n\t#----------------------------------------------------#");
26--
272.7.4
28
diff --git a/recipes-devtools/cst/cst_git.bb b/recipes-devtools/cst/cst_git.bb
index fcae0c79..dc0ae5e8 100644
--- a/recipes-devtools/cst/cst_git.bb
+++ b/recipes-devtools/cst/cst_git.bb
@@ -9,8 +9,10 @@ RDEPENDS_${PN} = "bash"
9 9
10inherit kernel-arch 10inherit kernel-arch
11 11
12SRC_URI = "git://github.com/qoriq-open-source/cst.git;nobranch=1" 12SRC_URI = "git://github.com/qoriq-open-source/cst.git;nobranch=1 \
13SRCREV = "6424157985568df3f42a46e24222e38671455ddb" 13 file://0001-gen_otpmk_drbg-fails-compilation-due-to-uninitialize.patch \
14"
15SRCREV = "1afb40c13097fc9e8a641aa5d0420498fea01c65"
14 16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16 18