summaryrefslogtreecommitdiffstats
path: root/recipes-daemons
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-09-21 10:28:16 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2020-09-22 21:54:23 -0300
commit7e9784a1907a04b954c63a7df302de8a5c5d93cc (patch)
tree649f16c2ee8fc800f5a4b929f910cbbdac91e1b8 /recipes-daemons
parent5afc3561a2203b21e238bdc5c8c0f4048625e8de (diff)
downloadmeta-freescale-7e9784a1907a04b954c63a7df302de8a5c5d93cc.tar.gz
ptpd-qoriq: remove as linuxptp is used instead
ptpd-qoriq is no longer used and supported, remove the recipe. Signed-off-by: Ting Liu <ting.liu@nxp.com> (cherry picked from commit 693fc486334c87a00c28cd68c2db5c1a41f709cf)
Diffstat (limited to 'recipes-daemons')
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq.bb67
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch35
2 files changed, 0 insertions, 102 deletions
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb
deleted file mode 100644
index 569deed5..00000000
--- a/recipes-daemons/ptpd/ptpd-qoriq.bb
+++ /dev/null
@@ -1,67 +0,0 @@
1SUMMARY = "The PTP daemon (PTPd)"
2DESCRIPTION = "The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as \
3defined by the relevant IEEE 1588 standard. PTP Version 1 implements IEEE-1588-2002, \
4and PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise \
5time coordination of LAN connected computers."
6HOMEPAGE = "http://sourceforge.net/projects/ptpd"
7SECTION = "net"
8LICENSE = "BSD"
9LIC_FILES_CHKSUM = "file://README;md5=0733e1b3788ab2ebbc63bf33a020da1d"
10
11COMPATIBLE_MACHINE = "(qoriq)"
12
13DEPENDS = "libpcap"
14
15PROVIDES = "ptpd"
16
17inherit autotools pkgconfig systemd
18
19python() {
20 pkgs = d.getVar('PACKAGES').split()
21 for p in pkgs:
22 if 'ptpd-qoriq' in p:
23 d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
24 d.appendVar("RCONFLICTS_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
25 d.appendVar("RREPLACES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
26}
27
28# return something like '1.2.3' or '1.2.3/rc1'
29#
30def get_sub(d):
31 parts = d.getVar('PV').split('-')
32 try:
33 return parts[0] + '/' + parts[1]
34 except:
35 return parts[0]
36
37SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ptpd;nobranch=1 \
38 file://ptpd-use-pkgconfig.patch \
39"
40SRCREV = "ec34cdd10446619d036ac8d6a86b8276f0d4a81c"
41
42S = "${WORKDIR}/git"
43
44EXTRA_OEMAKE = ""
45
46EXTRA_OECONF += "--disable-snmp --with-pcap-config=pkg-config"
47
48do_install() {
49 install -d ${D}${bindir} ${D}${mandir}/man8
50 install -m 0755 ${B}/src/ptpd2 ${D}${bindir}
51 install -m 0644 ${B}/src/ptpd2.8 ${D}${mandir}/man8
52
53 if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
54 install -d ${D}${systemd_unitdir}/system
55 install -m 0644 ${WORKDIR}/ptpd.service ${D}${systemd_unitdir}/system
56
57 sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/ptpd.service
58 sed -i -e 's#@BINDIR@#${bindir}#g' ${D}${systemd_unitdir}/system/ptpd.service
59
60 install -d ${D}${sysconfdir}/default/
61 install -m 0644 ${WORKDIR}/ptpd.conf ${D}${sysconfdir}/default/ptpd
62 fi
63}
64
65SYSTEMD_PACKAGES = "${PN}"
66SYSTEMD_SERVICE_${PN} = "ptpd.service"
67SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch b/recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch
deleted file mode 100644
index e4578dda..00000000
--- a/recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 4c850b92a1cf8cfa19677c66bcde2edfab1a4490 Mon Sep 17 00:00:00 2001
2From: Joe MacDonald <joe_macdonald@mentor.com>
3Date: Tue, 24 Feb 2015 23:02:14 -0500
4Subject: [PATCH] ptpd: use pkgconfig
5
6Yocto uses pkg-config for libpcap, rather than pcap-config, so use that
7instead as the source for libs and cflags.
8
9Upstream-status: Inappropriate [ embedded specific ]
10
11Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
12---
13 configure.ac | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index dc9541f..288f547 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -112,10 +112,10 @@ case "$try_pcap" in
21 yes)
22 case "$PATH_PCAP_CONFIG" in
23 /*)
24- PCAP_LIBS=`$PATH_PCAP_CONFIG --libs`
25+ PCAP_LIBS=`$PATH_PCAP_CONFIG --libs libpcap`
26 AC_SUBST([PCAP_LIBS])
27 # Separate CPPFLAGS and CFLAGS
28- foo=`$PATH_PCAP_CONFIG --cflags`
29+ foo=`$PATH_PCAP_CONFIG --cflags libpcap`
30 PCAP_CPPFLAGS=
31 PCAP_CFLAGS=
32 for i in $foo; do
33--
341.9.1
35