summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2018-10-25 10:18:24 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2018-10-25 10:28:56 -0300
commitf88986d77ef02a3b2c8db61c13aee123f92046c7 (patch)
tree38ee0439d1b14bc6ab02ae22fa82fb45b5bb13cc /recipes-bsp
parent382d502aaeceae64c1532ec835b4f064a347ec3e (diff)
downloadmeta-freescale-f88986d77ef02a3b2c8db61c13aee123f92046c7.tar.gz
imx-test: Disable string format security build flags
The code has some possible flaws related to string manipulation functions which are know to be fragile. This commit disables this protection but this should be fixed by NXP for next releases. Flags being disabled: - -Wformat - -Wformat-security - -Werror=format-security Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index b0567dc1..4590b1a4 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -48,6 +48,9 @@ PACKAGECONFIG_append_imxvpu = " vpu"
48PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr" 48PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
49PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu" 49PACKAGECONFIG[vpu] = "HAS_VPU=true,HAS_VPU=false,virtual/imxvpu"
50 50
51# FIXME: NXP should fix the possible string flaws from their code.
52SECURITY_STRINGFORMAT = ""
53
51do_compile() { 54do_compile() {
52 CFLAGS="${TOOLCHAIN_OPTIONS}" 55 CFLAGS="${TOOLCHAIN_OPTIONS}"
53 oe_runmake V=1 VERBOSE='' \ 56 oe_runmake V=1 VERBOSE='' \