summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-07-05 11:48:56 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-07-12 17:18:34 -0300
commitd9d4c44812dfbb8808ba3759e4ad21e76efb8c30 (patch)
tree7be6534a43a07887d8aa1dd228e38eeb5f1d1828 /recipes-bsp
parent1b1bddcdda2b71b8c1d8122e1671696b3f6340ad (diff)
downloadmeta-freescale-d9d4c44812dfbb8808ba3759e4ad21e76efb8c30.tar.gz
qe-ucode: update recipes
*install *.bin to boot *set COMPATIBLE_MACHINE to qoriq Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb15
1 files changed, 3 insertions, 12 deletions
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
index 9bac32d9..58dffa3b 100644
--- a/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -10,29 +10,20 @@ SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
12 12
13python () {
14 if not d.getVar("QE_UCODE"):
15 PN = d.getVar("PN")
16 FILE = os.path.basename(d.getVar("FILE"))
17 bb.debug(1, "To build %s, see %s for instructions on \
18 setting up your qe-ucode" % (PN, FILE))
19 raise bb.parse.SkipRecipe("because QE_UCODE is not set")
20}
21
22do_install () { 13do_install () {
23 install -d ${D}/boot 14 install -d ${D}/boot
24 install -m 644 ${B}/${QE_UCODE} ${D}/boot 15 install -m 644 ${B}/*.bin ${D}/boot
25} 16}
26 17
27do_deploy () { 18do_deploy () {
28 install -d ${DEPLOYDIR}/boot 19 install -d ${DEPLOYDIR}/boot
29 install -m 644 ${B}/${QE_UCODE} ${DEPLOYDIR}/boot 20 install -m 644 ${B}/*.bin ${DEPLOYDIR}/boot
30} 21}
31addtask deploy before do_build after do_install 22addtask deploy before do_build after do_install
32 23
33PACKAGES += "${PN}-image" 24PACKAGES += "${PN}-image"
34FILES_${PN}-image += "/boot/*" 25FILES_${PN}-image += "/boot/*"
35 26
36COMPATIBLE_MACHINE = "(ls1021a|ls1043a|t1042|t1024)" 27COMPATIBLE_MACHINE = "(qoriq)"
37PACKAGE_ARCH = "${MACHINE_SOCARCH}" 28PACKAGE_ARCH = "${MACHINE_SOCARCH}"
38 29