summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:10:20 +0100
committerPierre-Jean Texier <texier.pj2@gmail.com>2021-11-03 22:27:01 +0100
commitbef00d6e4f25b4a9d3272e0d69db7545590ed204 (patch)
tree93ee6b4fb459a7719aae1f3010d8c5d65be3e2b2 /recipes-bsp
parent16e922408678425a492bd109350cd217a0841280 (diff)
downloadmeta-freescale-bef00d6e4f25b4a9d3272e0d69db7545590ed204.tar.gz
recipes: use https protocol and add explicit branch parameter
Due to https://github.blog/2021-09-01-improving-git-protocol-security-github/#no-more-unauthenticated-git it is required to use https protocol for github repo accessing. Update created with oe-core/scripts/contrib/convert-srcuri.py (see [0]) Fixes: WARNING: /work/meta-freescale/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2021.07.bb: URL: git://github.com/Freescale/u-boot-fslc.git;branch=2021.07+fslc uses git protocol which is no longer supported by github. Please change to ;protocol=https in the url. [0] - https://git.openembedded.org/openembedded-core/tree/scripts/contrib/convert-srcuri.py Signed-off-by: Pierre-Jean Texier <texier.pj2@gmail.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/atf/qoriq-atf_2.4.bb2
-rw-r--r--recipes-bsp/ddr-phy/ddr-phy_git.bb2
-rw-r--r--recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb2
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_git.bb2
-rw-r--r--recipes-bsp/imx-uuc/imx-uuc_git.bb2
-rw-r--r--recipes-bsp/inphi/inphi_git.bb2
-rw-r--r--recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb2
-rw-r--r--recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb2
-rw-r--r--recipes-bsp/ls2-phy/ls2-phy_git.bb2
-rw-r--r--recipes-bsp/mxsldr/mxsldr_git.bb2
-rw-r--r--recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb2
-rw-r--r--recipes-bsp/qe-ucode/qe-ucode_git.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc2
-rw-r--r--recipes-bsp/uefi/uefi_git.bb2
14 files changed, 14 insertions, 14 deletions
diff --git a/recipes-bsp/atf/qoriq-atf_2.4.bb b/recipes-bsp/atf/qoriq-atf_2.4.bb
index 9c8937a2..0c490a72 100644
--- a/recipes-bsp/atf/qoriq-atf_2.4.bb
+++ b/recipes-bsp/atf/qoriq-atf_2.4.bb
@@ -7,7 +7,7 @@ DEPENDS:append:lx2160a += "ddr-phy"
7DEPENDS:append:lx2162a += "ddr-phy" 7DEPENDS:append:lx2162a += "ddr-phy"
8do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy" 8do_compile[depends] += "u-boot:do_deploy rcw:do_deploy uefi:do_deploy"
9 9
10SRC_URI += "git://github.com/ARMmbed/mbedtls;nobranch=1;destsuffix=git/mbedtls;name=mbedtls" 10SRC_URI += "git://github.com/ARMmbed/mbedtls;nobranch=1;destsuffix=git/mbedtls;name=mbedtls;protocol=https"
11SRCREV_mbedtls = "0795874acdf887290b2571b193cafd3c4041a708" 11SRCREV_mbedtls = "0795874acdf887290b2571b193cafd3c4041a708"
12SRCREV_FORMAT = "atf" 12SRCREV_FORMAT = "atf"
13 13
diff --git a/recipes-bsp/ddr-phy/ddr-phy_git.bb b/recipes-bsp/ddr-phy/ddr-phy_git.bb
index 6e68bd02..8ea92502 100644
--- a/recipes-bsp/ddr-phy/ddr-phy_git.bb
+++ b/recipes-bsp/ddr-phy/ddr-phy_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=89cc852481956e861228286ac7430
4 4
5inherit deploy 5inherit deploy
6 6
7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;nobranch=1" 7SRC_URI = "git://github.com/nxp/ddr-phy-binary.git;nobranch=1;protocol=https"
8SRCREV = "fbc036b88acb6c06ffed02c898cbae9856ec75ba" 8SRCREV = "fbc036b88acb6c06ffed02c898cbae9856ec75ba"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb b/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb
index 287b1cff..5a7e6a1d 100644
--- a/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb
+++ b/recipes-bsp/firmware-imx/firmware-nxp-wifi_1.0.bb
@@ -10,7 +10,7 @@ SECTION = "kernel"
10LICENSE = "Proprietary" 10LICENSE = "Proprietary"
11LIC_FILES_CHKSUM = "file://cyw-wifi-bt/EULA.txt;md5=80c0478f4339af024519b3723023fe28" 11LIC_FILES_CHKSUM = "file://cyw-wifi-bt/EULA.txt;md5=80c0478f4339af024519b3723023fe28"
12 12
13SRC_URI = "git://github.com/NXP/imx-firmware.git;protocol=https" 13SRC_URI = "git://github.com/NXP/imx-firmware.git;protocol=https;branch=master"
14SRCREV = "484d38224fa2c26b8859a7bf20b7c4d49100f5bc" 14SRCREV = "484d38224fa2c26b8859a7bf20b7c4d49100f5bc"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-kobs/imx-kobs_git.bb b/recipes-bsp/imx-kobs/imx-kobs_git.bb
index d93a3f25..58bd44f8 100644
--- a/recipes-bsp/imx-kobs/imx-kobs_git.bb
+++ b/recipes-bsp/imx-kobs/imx-kobs_git.bb
@@ -8,7 +8,7 @@ LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833" 8LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
9 9
10PV = "5.5+git${SRCPV}" 10PV = "5.5+git${SRCPV}"
11SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocol=https \ 11SRC_URI = "git://github.com/NXPmicro/imx-kobs.git;protocol=https;branch=master \
12" 12"
13SRCREV = "269fdffcf97238684de9f28977a73677282e061f" 13SRCREV = "269fdffcf97238684de9f28977a73677282e061f"
14S = "${WORKDIR}/git" 14S = "${WORKDIR}/git"
diff --git a/recipes-bsp/imx-uuc/imx-uuc_git.bb b/recipes-bsp/imx-uuc/imx-uuc_git.bb
index 02331a80..0de2ad85 100644
--- a/recipes-bsp/imx-uuc/imx-uuc_git.bb
+++ b/recipes-bsp/imx-uuc/imx-uuc_git.bb
@@ -11,7 +11,7 @@ inherit autotools-brokensep
11PR = "r1" 11PR = "r1"
12PV = "0.5.1+git${SRCPV}" 12PV = "0.5.1+git${SRCPV}"
13 13
14SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https" 14SRC_URI = "git://github.com/NXPmicro/imx-uuc.git;protocol=https;branch=master"
15SRCREV = "d6afb27e55d73d7ad08cd2dd51c784d8ec9694dc" 15SRCREV = "d6afb27e55d73d7ad08cd2dd51c784d8ec9694dc"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
diff --git a/recipes-bsp/inphi/inphi_git.bb b/recipes-bsp/inphi/inphi_git.bb
index 314f09d4..4deacb58 100644
--- a/recipes-bsp/inphi/inphi_git.bb
+++ b/recipes-bsp/inphi/inphi_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
4 4
5inherit deploy 5inherit deploy
6 6
7SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;nobranch=1" 7SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;nobranch=1;protocol=https"
8SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695" 8SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb b/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb
index 363f7305..07d52355 100644
--- a/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb
+++ b/recipes-bsp/isp-imx/libtinyxml2-8_8.0.0.bb
@@ -4,7 +4,7 @@ SECTION = "libs"
4LICENSE = "Zlib" 4LICENSE = "Zlib"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd" 5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd"
6 6
7SRC_URI = "git://github.com/leethomason/tinyxml2.git" 7SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https"
8 8
9SRCREV = "bf15233ad88390461f6ab0dbcf046cce643c5fcb" 9SRCREV = "bf15233ad88390461f6ab0dbcf046cce643c5fcb"
10 10
diff --git a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
index e57a4273..38481b54 100644
--- a/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
+++ b/recipes-bsp/libimxdmabuffer/libimxdmabuffer_1.0.1.bb
@@ -9,7 +9,7 @@ PV .= "+git${SRCPV}"
9 9
10SRCBRANCH ?= "master" 10SRCBRANCH ?= "master"
11SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514" 11SRCREV = "d2058aa404ee1e8e8abd552c6a637787bcdcf514"
12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH} \ 12SRC_URI = "git://github.com/Freescale/libimxdmabuffer.git;branch=${SRCBRANCH};protocol=https \
13 file://run-ptest \ 13 file://run-ptest \
14 " 14 "
15 15
diff --git a/recipes-bsp/ls2-phy/ls2-phy_git.bb b/recipes-bsp/ls2-phy/ls2-phy_git.bb
index dd5f8fc0..c13a05a1 100644
--- a/recipes-bsp/ls2-phy/ls2-phy_git.bb
+++ b/recipes-bsp/ls2-phy/ls2-phy_git.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
4 4
5inherit deploy 5inherit deploy
6 6
7SRC_URI = "git://github.com/nxp/qoriq-firmware-cortina.git;nobranch=1" 7SRC_URI = "git://github.com/nxp/qoriq-firmware-cortina.git;nobranch=1;protocol=https"
8SRCREV = "9143c2a3adede595966583c00ca4edc99ec698cf" 8SRCREV = "9143c2a3adede595966583c00ca4edc99ec698cf"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
diff --git a/recipes-bsp/mxsldr/mxsldr_git.bb b/recipes-bsp/mxsldr/mxsldr_git.bb
index 01e24993..62b4b7ad 100644
--- a/recipes-bsp/mxsldr/mxsldr_git.bb
+++ b/recipes-bsp/mxsldr/mxsldr_git.bb
@@ -7,7 +7,7 @@ LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" 7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
8 8
9SRCREV = "c40d80472525e1d57dae5317c028b745968c0399" 9SRCREV = "c40d80472525e1d57dae5317c028b745968c0399"
10SRC_URI = "git://git.denx.de/mxsldr.git \ 10SRC_URI = "git://git.denx.de/mxsldr.git;branch=master \
11 file://0001-Do-not-ignore-OE-cflags-and-ldflags.patch \ 11 file://0001-Do-not-ignore-OE-cflags-and-ldflags.patch \
12 " 12 "
13 13
diff --git a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
index 5c97486e..c01bfd4c 100644
--- a/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
+++ b/recipes-bsp/ppfe-firmware/ppfe-firmware_git.bb
@@ -7,7 +7,7 @@ INHIBIT_DEFAULT_DEPS = "1"
7 7
8inherit deploy 8inherit deploy
9 9
10SRC_URI = "git://github.com/NXP/qoriq-engine-pfe-bin.git;nobranch=1" 10SRC_URI = "git://github.com/NXP/qoriq-engine-pfe-bin.git;nobranch=1;protocol=https"
11SRCREV = "f55ee9f72090309bbb7ab71f48a498fc02909234" 11SRCREV = "f55ee9f72090309bbb7ab71f48a498fc02909234"
12 12
13S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
diff --git a/recipes-bsp/qe-ucode/qe-ucode_git.bb b/recipes-bsp/qe-ucode/qe-ucode_git.bb
index 19cb79e0..33648d1e 100644
--- a/recipes-bsp/qe-ucode/qe-ucode_git.bb
+++ b/recipes-bsp/qe-ucode/qe-ucode_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=c62f8109b4df15ca37ceeb5e4943626c"
5 5
6inherit deploy 6inherit deploy
7 7
8SRC_URI = "git://github.com/NXP/qoriq-qe-ucode.git;nobranch=1" 8SRC_URI = "git://github.com/NXP/qoriq-qe-ucode.git;nobranch=1;protocol=https"
9SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46" 9SRCREV= "57401f6dff6507055558eaa6838116baa8a2fd46"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
index 3c56a8f2..7d401692 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2021.07.inc
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = "file://Licenses/README;md5=5a7450c57ffe5ae63fd732446b988025"
8 8
9DEPENDS += "flex-native bison-native" 9DEPENDS += "flex-native bison-native"
10 10
11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https"
12 12
13SRCREV = "691e634bfd317ede487d2b864a126847ffeb4aa7" 13SRCREV = "691e634bfd317ede487d2b864a126847ffeb4aa7"
14SRCBRANCH = "2021.07+fslc" 14SRCBRANCH = "2021.07+fslc"
diff --git a/recipes-bsp/uefi/uefi_git.bb b/recipes-bsp/uefi/uefi_git.bb
index 6174e258..d7ef0b72 100644
--- a/recipes-bsp/uefi/uefi_git.bb
+++ b/recipes-bsp/uefi/uefi_git.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=343ec8f06efc37467a6de53686fa6315"
5 5
6inherit deploy 6inherit deploy
7 7
8SRC_URI = "git://github.com/NXP/qoriq-uefi-binary.git;nobranch=1" 8SRC_URI = "git://github.com/NXP/qoriq-uefi-binary.git;nobranch=1;protocol=https"
9SRCREV= "1b28cad962a3f7b61baae2229cb3b84926941cfa" 9SRCREV= "1b28cad962a3f7b61baae2229cb3b84926941cfa"
10 10
11S = "${WORKDIR}/git" 11S = "${WORKDIR}/git"