summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorGary Bisson <gary.bisson@boundarydevices.com>2018-07-12 12:07:17 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2018-07-12 09:38:11 -0300
commitbe29af7fe5d90b67a7208ba8f1b3881067b95c8c (patch)
tree8c334734d2d4fd675132250b4e5f75eb0f7fb249 /recipes-bsp
parent02fc6a68ecc9d76cdaeca483b70dc37180e2e7f8 (diff)
downloadmeta-freescale-be29af7fe5d90b67a7208ba8f1b3881067b95c8c.tar.gz
imx-vpu-hantro: add recipe for i.MX8MQ Hantro VPU
Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch44
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb33
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
new file mode 100644
index 00000000..951ead98
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro-1.6.0/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
@@ -0,0 +1,44 @@
1From 872c82e7cbb9a0a0e761e8ac70fc28e19a55b4c3 Mon Sep 17 00:00:00 2001
2From: Gary Bisson <gary.bisson@boundarydevices.com>
3Date: Thu, 12 Jul 2018 11:38:28 +0200
4Subject: [PATCH] Fix ion.h header inclusion to be standard
5
6NXP "solution" was to manually copy the header to include/linux.
7Let's point the Makefile to the proper (mainline) location instead:
8https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
9
10Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
11---
12 Makefile | 2 ++
13 decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
14 2 files changed, 3 insertions(+), 1 deletion(-)
15
16diff --git a/Makefile b/Makefile
17index b74e23a..a5ce22b 100755
18--- a/Makefile
19+++ b/Makefile
20@@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOURCE_ROOT)/source/inc -I$(SOURCE_ROOT)/so
21 INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
22 #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
23 INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
24+# ION header location
25+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
26
27 CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
28 -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
29diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c
30index 8183660..ed37d86 100644
31--- a/decoder_sw/software/linux/dwl/dwl_linux.c
32+++ b/decoder_sw/software/linux/dwl/dwl_linux.c
33@@ -41,7 +41,7 @@
34 #include "dwl.h"
35 #include <linux/hantrodec.h>
36 #ifdef USE_ION
37-#include <linux/ion.h>
38+#include <ion.h>
39 #ifdef ANDROID
40 #include <linux/mxc_ion.h>
41 #endif
42--
432.18.0
44
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
new file mode 100644
index 00000000..609d6928
--- /dev/null
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.6.0.bb
@@ -0,0 +1,33 @@
1# Copyright 2017 NXP
2
3DESCRIPTION = "i.MX Hantro VPU library"
4LICENSE = "Proprietary"
5LIC_FILES_CHKSUM = "file://COPYING;md5=08fd295cce89b0a9c74b9b83ed74f671"
6
7DEPENDS = "virtual/kernel"
8
9PROVIDES = "virtual/imxvpu"
10
11SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
12 file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \
13"
14
15SRC_URI[md5sum] = "09ec833586afb5f194ce0202da925ed6"
16SRC_URI[sha256sum] = "cbc648e41f005aad209f74c9e5dd346138dca12efeb7b27e471de7474c4da302"
17
18inherit fsl-eula-unpack
19
20PARALLEL_MAKE="-j 1"
21
22do_compile () {
23 oe_runmake CROSS_COMPILE="${HOST_PREFIX}" LINUX_KERNEL_ROOT="${STAGING_KERNEL_DIR}" SDKTARGETSYSROOT="${STAGING_DIR_TARGET}" all
24}
25
26do_install () {
27 oe_runmake DEST_DIR="${D}" install
28}
29
30FILES_${PN} += "/unit_tests"
31
32PACKAGE_ARCH = "${MACHINE_ARCH}"
33COMPATIBLE_MACHINE = "(mx8mq)"