summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorMax Krummenacher <max.oss.09@gmail.com>2019-01-28 16:05:49 +0100
committerDaiane Angolini <daiane.angolini@nxp.com>2019-01-29 15:03:40 -0200
commit95c1f9561b94ce3fadfa105a1773440898b5564b (patch)
treec338645a45934da1f2d8cacc410634193ae54484 /recipes-bsp
parenteca805edf60e8864003fcc828408c37d58391a9b (diff)
downloadmeta-freescale-95c1f9561b94ce3fadfa105a1773440898b5564b.tar.gz
imx-boot: imx-mkimage: do not compile with -static
E.g. Fedora doesn't install glibc-static by default and the yocto prerequisites do not mandate installing it. Rather than requiring glibc-static drop linking with -static. Works around: | .../build/tmp/hosttools/ld: cannot find -lc Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_0.2.bb2
-rw-r--r--recipes-bsp/imx-mkimage/imx-mkimage_git.bb2
2 files changed, 2 insertions, 2 deletions
diff --git a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
index 30a732fa..68492a9b 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_0.2.bb
@@ -23,7 +23,7 @@ PROVIDES = "${BOOT_NAME}"
23inherit deploy 23inherit deploy
24 24
25# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build 25# Add CFLAGS with native INCDIR & LIBDIR for imx-mkimage build
26CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}" 26CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR_NATIVE} -L ${STAGING_LIBDIR_NATIVE}"
27 27
28# This package aggregates output deployed by other packages, 28# This package aggregates output deployed by other packages,
29# so set the appropriate dependencies 29# so set the appropriate dependencies
diff --git a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb
index b0a2719f..5304ebf9 100644
--- a/recipes-bsp/imx-mkimage/imx-mkimage_git.bb
+++ b/recipes-bsp/imx-mkimage/imx-mkimage_git.bb
@@ -10,7 +10,7 @@ SECTION = "BSP"
10 10
11inherit native deploy 11inherit native deploy
12 12
13CFLAGS = "-O2 -Wall -std=c99 -static -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}" 13CFLAGS = "-O2 -Wall -std=c99 -I ${STAGING_INCDIR} -L ${STAGING_LIBDIR}"
14 14
15do_compile () { 15do_compile () {
16 cd ${S} 16 cd ${S}