summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2022-07-29 18:21:01 -0300
committerGitHub <noreply@github.com>2022-07-29 18:21:01 -0300
commit8b801b824e696babbe1569e8f53657f83694ce71 (patch)
treefcf9d6ff9237b85bc4109199366baede27d1e7a7 /recipes-bsp
parent10f4c0df3437696a3be3851cdc909b3d5dc94b41 (diff)
parentb511d2ad3ba4b8175b68eca8410ff8cb1c7d2792 (diff)
downloadmeta-freescale-8b801b824e696babbe1569e8f53657f83694ce71.tar.gz
Merge pull request #1153 from Freescale/backport-1141-to-kirkstone
[Backport kirkstone] Secure boot rework
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.6.bb16
-rw-r--r--recipes-bsp/imx-mkimage/imx-boot_1.0.bb3
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2022.07.bb6
3 files changed, 12 insertions, 13 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.6.bb b/recipes-bsp/imx-atf/imx-atf_2.6.bb
index b0cd4d3d..194ef935 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.6.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.6.bb
@@ -18,9 +18,11 @@ S = "${WORKDIR}/git"
18 18
19inherit deploy 19inherit deploy
20 20
21BOOT_TOOLS = "imx-boot-tools" 21ATF_PLATFORM ??= "INVALID"
22 22
23ATF_PLATFORM ??= "INVALID" 23# FIXME: We should return INVALID here but currently only i.MX8M has support to override the UART
24# base address in source code.
25ATF_BOOT_UART_BASE ?= ""
24 26
25EXTRA_OEMAKE += " \ 27EXTRA_OEMAKE += " \
26 CROSS_COMPILE="${TARGET_PREFIX}" \ 28 CROSS_COMPILE="${TARGET_PREFIX}" \
@@ -34,7 +36,8 @@ AS[unexport] = "1"
34LD[unexport] = "1" 36LD[unexport] = "1"
35 37
36# Baremetal, just need a compiler 38# Baremetal, just need a compiler
37DEPENDS:remove = "virtual/${TARGET_PREFIX}compilerlibs virtual/libc" 39INHIBIT_DEFAULT_DEPS = "1"
40DEPENDS = "virtual/${HOST_PREFIX}gcc"
38 41
39BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 42BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
40 43
@@ -49,6 +52,11 @@ EXTRA_OEMAKE += 'LD="${@remove_options_tail(d.getVar('LD'))}"'
49 52
50EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"' 53EXTRA_OEMAKE += 'CC="${@remove_options_tail(d.getVar('CC'))}"'
51 54
55# Set the UART to use during the boot.
56EXTRA_OEMAKE += 'IMX_BOOT_UART_BASE=${ATF_BOOT_UART_BASE}'
57
58do_configure[noexec] = "1"
59
52do_compile() { 60do_compile() {
53 # Clear LDFLAGS to avoid the option -Wl recognize issue 61 # Clear LDFLAGS to avoid the option -Wl recognize issue
54 oe_runmake bl31 62 oe_runmake bl31
@@ -68,5 +76,5 @@ do_deploy() {
68} 76}
69addtask deploy after do_compile 77addtask deploy after do_compile
70 78
71PACKAGE_ARCH = "${MACHINE_SOCARCH}" 79PACKAGE_ARCH = "${MACHINE_ARCH}"
72COMPATIBLE_MACHINE = "(mx8-generic-bsp)" 80COMPATIBLE_MACHINE = "(mx8-generic-bsp)"
diff --git a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
index f35561de..ae7e2638 100644
--- a/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
+++ b/recipes-bsp/imx-mkimage/imx-boot_1.0.bb
@@ -9,9 +9,6 @@ SECTION = "BSP"
9 9
10inherit use-imx-security-controller-firmware uboot-sign 10inherit use-imx-security-controller-firmware uboot-sign
11 11
12IMX_EXTRA_FIRMWARE = "firmware-imx-8 imx-sc-firmware imx-seco"
13IMX_EXTRA_FIRMWARE:mx8m-generic-bsp = "firmware-imx-8m"
14IMX_EXTRA_FIRMWARE:mx8x-generic-bsp = "imx-sc-firmware imx-seco"
15DEPENDS += " \ 12DEPENDS += " \
16 u-boot \ 13 u-boot \
17 ${IMX_EXTRA_FIRMWARE} \ 14 ${IMX_EXTRA_FIRMWARE} \
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb b/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
index de6d22d0..1953d788 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2022.07.bb
@@ -10,12 +10,6 @@ inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'im
10 10
11DEPENDS += "bc-native dtc-native python3-setuptools-native" 11DEPENDS += "bc-native dtc-native python3-setuptools-native"
12 12
13# Location known to imx-boot component, where U-Boot artifacts
14# should be additionally deployed.
15# See below note above do_deploy:append:mx8m-nxp-bsp for the purpose of
16# this delopyment location
17BOOT_TOOLS = "imx-boot-tools"
18
19PROVIDES += "u-boot" 13PROVIDES += "u-boot"
20 14
21B = "${WORKDIR}/build" 15B = "${WORKDIR}/build"