summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2021-06-30 07:10:22 -0500
committerTom Hochstein <tom.hochstein@nxp.com>2021-07-02 08:05:13 -0500
commit79ba26618a075332ac9106f55c1aad573e42c9e0 (patch)
tree68f1c77388dd2509bf6885e4140ec6505d463c8a /recipes-bsp
parent0b01dbe8593b355a96998080c551e0570c82d037 (diff)
downloadmeta-freescale-79ba26618a075332ac9106f55c1aad573e42c9e0.tar.gz
imx-atf: Remove -O2 from CFLAGS for 8MQ
The i.MX 8M Quad has only 64 kB of OCRAM, and the following build break is observed: ``` | aarch64-poky-linux-ld.bfd: /opt/work/upstream/fsl-xwayland/tmp/work/cortexa53-crypto-mx8m-fsl-linux/imx-atf/2.4+gitAUTOINC+ec35fef92b-r0/git/build-optee/imx8mq/release/bl31/bl31.elf section `coherent_ram' will not fit in region `RAM' | aarch64-poky-linux-ld.bfd: BL31 image has exceeded its limit. | aarch64-poky-linux-ld.bfd: region `RAM' overflowed by 4096 bytes ``` Fix the break by disabling -O2 optimization. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-atf/imx-atf_2.4.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf_2.4.bb b/recipes-bsp/imx-atf/imx-atf_2.4.bb
index 26b9e7d1..f4db002b 100644
--- a/recipes-bsp/imx-atf/imx-atf_2.4.bb
+++ b/recipes-bsp/imx-atf/imx-atf_2.4.bb
@@ -27,6 +27,8 @@ EXTRA_OEMAKE += " \
27 27
28BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}" 28BUILD_OPTEE = "${@bb.utils.contains('MACHINE_FEATURES', 'optee', 'true', 'false', d)}"
29 29
30CFLAGS_remove_mx8mq = "-O2"
31
30do_compile() { 32do_compile() {
31 # Clear LDFLAGS to avoid the option -Wl recognize issue 33 # Clear LDFLAGS to avoid the option -Wl recognize issue
32 unset LDFLAGS 34 unset LDFLAGS