diff options
author | Andrey Zhizhikin <andrey.z@gmail.com> | 2021-10-19 18:31:36 +0000 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2021-10-25 15:21:08 +0000 |
commit | 5e2bce350ea6ac77798c9d315ce76224c185db14 (patch) | |
tree | d312aa360cf0625af0a9927acac9c8f749d80b05 /recipes-bsp | |
parent | 9b3cbb3ef44ad5aba498af3345251c5173fd17d6 (diff) | |
download | meta-freescale-5e2bce350ea6ac77798c9d315ce76224c185db14.tar.gz |
imx-lib: upgrade to 5.10.52_2.1.0
Update branch, SRCREV and PV to point to new version, add support for
mx8ulp.
Following commits are included in this revision:
----
87ddd80 ("lib: pxp: add DMABUF support for pxp lib")
7fc4448 ("lib: pxp: remove unsigned long force type conversion")
5ac2f74 ("lib: pxp: Makefile: Add iMX8ULP platform support")
d09fbbc ("MA-15553-1 Amend Cflag & Cppflag in go file")
026eefc ("MA-15263-3 convert Android.mk to Android.bp")
fcf9171 ("MA-14403 Bring imx6/7 soc on q-preview (LOCAL_MODULE_TAGS)")
----
Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
(cherry picked from commit 87cb0d99eab87c2be842a921bd5d9e9a36df547c)
Diffstat (limited to 'recipes-bsp')
-rw-r--r-- | recipes-bsp/imx-lib/imx-lib_git.bb | 10 |
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes-bsp/imx-lib/imx-lib_git.bb b/recipes-bsp/imx-lib/imx-lib_git.bb index a296b185..fd912ca1 100644 --- a/recipes-bsp/imx-lib/imx-lib_git.bb +++ b/recipes-bsp/imx-lib/imx-lib_git.bb | |||
@@ -10,11 +10,12 @@ LIC_FILES_CHKSUM = "file://COPYING-LGPL-2.1;md5=fbc093901857fcd118f065f900982c24 | |||
10 | 10 | ||
11 | PE = "1" | 11 | PE = "1" |
12 | 12 | ||
13 | PV = "5.8+${SRCPV}" | 13 | PV = "5.9+${SRCPV}" |
14 | |||
15 | SRCBRANCH = "lf-5.10.52_2.1.0" | ||
14 | 16 | ||
15 | SRCBRANCH = "master" | ||
16 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-lib.git;protocol=https;branch=${SRCBRANCH}" | 17 | SRC_URI = "git://source.codeaurora.org/external/imx/imx-lib.git;protocol=https;branch=${SRCBRANCH}" |
17 | SRCREV = "3f777974c0c146817e2ff5cb0340ca66a1f99e57" | 18 | SRCREV = "87ddd80953835eb29027d1d5a12044a08e809e40" |
18 | 19 | ||
19 | S = "${WORKDIR}/git" | 20 | S = "${WORKDIR}/git" |
20 | 21 | ||
@@ -29,6 +30,7 @@ PLATFORM:mx6ul = "IMX6UL" | |||
29 | PLATFORM:mx6ull = "IMX6UL" | 30 | PLATFORM:mx6ull = "IMX6UL" |
30 | PLATFORM:mx7d = "IMX7" | 31 | PLATFORM:mx7d = "IMX7" |
31 | PLATFORM:mx7ulp = "IMX7" | 32 | PLATFORM:mx7ulp = "IMX7" |
33 | PLATFORM:mx8ulp = "IMX8ULP" | ||
32 | 34 | ||
33 | PARALLEL_MAKE="-j 1" | 35 | PARALLEL_MAKE="-j 1" |
34 | EXTRA_OEMAKE = "" | 36 | EXTRA_OEMAKE = "" |
@@ -42,4 +44,4 @@ do_install () { | |||
42 | oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install | 44 | oe_runmake PLATFORM="${PLATFORM}" DEST_DIR="${D}" install |
43 | } | 45 | } |
44 | 46 | ||
45 | COMPATIBLE_MACHINE = "(mx6|mx7)" | 47 | COMPATIBLE_MACHINE = "(mx6|mx7|mx8ulp)" |