summaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2018-08-21 16:41:47 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-08-30 22:07:12 -0300
commit542af201f5048fd0d7ff093a2f2426ea039883a7 (patch)
treef4552332a3b766055ebbd95f675879213fcbbafe /recipes-bsp
parent23fffcaed5a88a511af84071d8213ec59b2e2efc (diff)
downloadmeta-freescale-542af201f5048fd0d7ff093a2f2426ea039883a7.tar.gz
rcw-bin: remove
*rcw-bin merge to rcw Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/rcw/rcw-bin_git.bb32
1 files changed, 0 insertions, 32 deletions
diff --git a/recipes-bsp/rcw/rcw-bin_git.bb b/recipes-bsp/rcw/rcw-bin_git.bb
deleted file mode 100644
index 420d9641..00000000
--- a/recipes-bsp/rcw/rcw-bin_git.bb
+++ /dev/null
@@ -1,32 +0,0 @@
1SUMMARY = "Reset Configuration Word"
2DESCRIPTION = "Reset Configuration Word - hardware boot-time parameters for the QorIQ targets"
3LICENSE = "NXP-Binary-EULA"
4LIC_FILES_CHKSUM = "file://NXP-Binary-EULA;md5=ba5ff3a3faf52a38970d0a536ef42df5"
5
6inherit deploy siteinfo
7
8SRC_URI = "git://github.com/NXP/qoriq-rcw-bin.git;nobranch=1"
9SRCREV = "a48f3adeff3c2e54ef8b888ec629fa2d576461da"
10
11S = "${WORKDIR}/git"
12
13M="${@d.getVar('MACHINE', True).replace('-64b','').replace('-32b','').replace('-${SITEINFO_ENDIANNESS}','')}"
14
15do_install () {
16 install -d ${D}/boot/rcw
17 cp -rf ${S}/${M}* ${D}/boot/rcw/
18 chown -R root:root ${D}
19}
20
21do_deploy () {
22 install -d ${DEPLOYDIR}/rcw
23 cp -rf ${S}/${M}* ${DEPLOYDIR}/rcw/
24}
25addtask deploy before do_build after do_install
26
27PACKAGES += "${PN}-image"
28FILES_${PN}-image += "/boot"
29
30COMPATIBLE_MACHINE = "(qoriq)"
31PACKAGE_ARCH = "${MACHINE_ARCH}"
32COMPATIBLE_MACHINE = "(ls1012a|ls2088a|ls1088a)"